Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70794 - [obs-studio] [vlc] VLC is not build with same Lua package as OBS causing segfault

Attached to Project: Community Packages
Opened by Trystan Mata (tytan652) - Tuesday, 11 May 2021, 08:40 GMT
Last edited by Jonathan Steel (jsteel) - Saturday, 05 June 2021, 12:26 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jonathan Steel (jsteel)
David Runge (dvzrv)
Levente Polyak (anthraxx)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Using VLC sources in OBS will provoke "Segmentation fault" because VLC and OBS have not been built with the same Lua package.


Additional info:
* luajit is used for obs-studio
* lua52 is used for vlc

Steps to reproduce:
Just add a VLC source and or switch to a scene with a VLC sources will cause a crash
This task depends upon

Closed by  Jonathan Steel (jsteel)
Saturday, 05 June 2021, 12:26 GMT
Reason for closing:  Implemented
Additional comments about closing:  Disabled the broken VLC support in obs 27.0.0-1
Comment by Trystan Mata (tytan652) - Tuesday, 11 May 2021, 08:44 GMT
I forgot to specify that luajit shall be installed as optional dependency for OBS to enable lua scripting
Comment by Trystan Mata (tytan652) - Sunday, 30 May 2021, 09:12 GMT
If you don't want OBS users to crash because of this incompatibility.

You can build VLC with luajit

OR

Disable VLC sources compilation from OBS with the `DISABLE_VLC` cmake flag
Comment by Jonathan Steel (jsteel) - Sunday, 30 May 2021, 09:27 GMT
I assume we don't want to change the VLC dep? And if that's true I'll try the second option.

Loading...