Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70788 - cmake-gui fails if qt6-base is optional dependency

Attached to Project: Arch Linux
Opened by mark (qinohe) - Monday, 10 May 2021, 20:48 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 10 May 2021, 21:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Cmake has optional dependency 'qt6-base' need to be depend on (cmake-gui)

error:
cmake-gui: error while loading shared libraries: libQt6Widgets.so.6: cannot open shared object file: No such file or directory

Discovered after creating a custom Archiso - need to rebuild with 'qt6-base' explicitly installed.

Steps to reproduce:
Build Archiso/releng with a WM or at least X and 'cmake' installed
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 10 May 2021, 21:19 GMT
Reason for closing:  Not a bug
Additional comments about closing:  cmake-gui is optional and hence fails if you don't include the optional dependency needed to make optional stuff work.

This should not come as a surprise.

Loading...