Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70785 - [virtualbox-guest-utils] vboxsf broken

Attached to Project: Community Packages
Opened by Miles Whittaker (mjwhitta) - Monday, 10 May 2021, 18:40 GMT
Last edited by Christian Hesse (eworm) - Wednesday, 12 May 2021, 05:57 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The vboxsf module appears to not build anymore and therefore shared folders are broken.

Additional info:

Here is the output of some commands that I hope are useful:

$ pacman -Qi virtualbox-guest-utils virtualbox-guest-dkms
Name : virtualbox-guest-utils
Version : 6.1.22-1
Description : VirtualBox Guest userspace utilities
Architecture : x86_64
URL : https://virtualbox.org/
Licenses : GPL custom
Groups : None
Provides : None
Depends On : glibc pam libx11 libxcomposite libxdamage libxext libxfixes libxmu libxt xorg-xrandr xf86-video-vmware VIRTUALBOX-GUEST-MODULES
Optional Deps : None
Required By : None
Optional For : None
Conflicts With : virtualbox-archlinux-additions virtualbox-guest-additions virtualbox-guest-utils-nox
Replaces : virtualbox-archlinux-additions virtualbox-guest-additions
Installed Size : 9.06 MiB
Packager : Christian Hesse <arch@eworm.de>
Build Date : Thu 29 Apr 2021 05:47:03 PM EDT
Install Date : Mon 10 May 2021 01:46:31 PM EDT
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

Name : virtualbox-guest-dkms
Version : 6.1.22-1
Description : VirtualBox Guest kernel modules sources
Architecture : x86_64
URL : https://virtualbox.org/
Licenses : GPL custom
Groups : None
Provides : VIRTUALBOX-GUEST-MODULES
Depends On : dkms gcc make
Optional Deps : None
Required By : virtualbox-guest-utils
Optional For : None
Conflicts With : virtualbox-archlinux-source virtualbox-guest-source
Replaces : virtualbox-archlinux-source virtualbox-guest-source virtualbox-guest-modules-lts
Installed Size : 101.25 KiB
Packager : Christian Hesse <arch@eworm.de>
Build Date : Thu 29 Apr 2021 05:47:03 PM EDT
Install Date : Mon 10 May 2021 01:46:31 PM EDT
Install Reason : Explicitly installed
Install Script : Yes
Validated By : Signature

$ systemctl status vboxservice
● vboxservice.service - VirtualBox Guest Service
Loaded: loaded (/usr/lib/systemd/system/vboxservice.service; enabled; vendor preset: disabled)
Active: active (running) since Mon 2021-05-10 13:56:58 EDT; 32min ago
Process: 339 ExecStartPre=/usr/bin/modprobe vboxguest (code=exited, status=0/SUCCESS)
Process: 340 ExecStartPre=/usr/bin/modprobe vboxvideo (code=exited, status=0/SUCCESS)
Process: 344 ExecStartPre=/usr/bin/modprobe vboxsf (code=exited, status=1/FAILURE)
Main PID: 346 (VBoxService)
Tasks: 9 (limit: 4679)
Memory: 3.1M
CPU: 547ms
CGroup: /system.slice/vboxservice.service
└─346 /usr/bin/VBoxService -f

May 10 13:57:07 rtnemesis VBoxService[346]: 17:57:07.263501 main Log opened 2021-05-10T17:57:07.263041000Z
May 10 13:57:07 rtnemesis VBoxService[346]: 17:57:07.263573 main OS Product: Linux
May 10 13:57:07 rtnemesis VBoxService[346]: 17:57:07.263605 main OS Release: 5.12.2-arch1-1
May 10 13:57:07 rtnemesis VBoxService[346]: 17:57:07.263636 main OS Version: #1 SMP PREEMPT Fri, 07 May 2021 15:36:06 +0000
May 10 13:57:07 rtnemesis VBoxService[346]: 17:57:07.263665 main Executable: /usr/bin/VBoxService
May 10 13:57:07 rtnemesis VBoxService[346]: 17:57:07.263666 main Process ID: 346
May 10 13:57:07 rtnemesis VBoxService[346]: 17:57:07.263667 main Package type: LINUX_64BITS_GENERIC (OSE)
May 10 13:57:07 rtnemesis VBoxService[346]: 17:57:07.265052 main 6.1.22 r144080 started. Verbose level = 0
May 10 13:57:07 rtnemesis VBoxService[346]: 17:57:07.306586 automount Error: vbsvcAutomounterMountIt: Failed to mount 'Windows' on '/media/sf_Windows': No such device (-1,19)
May 10 13:57:08 rtnemesis VBoxService[346]: 17:57:08.343528 automount Error: vbsvcAutomounterMountIt: Failed to mount 'Windows' on '/media/sf_Windows': No such device (-1,19)

$ sudo /usr/bin/modprobe vboxsf
modprobe: ERROR: could not insert 'vboxsf': Unknown symbol in module, or unknown parameter (see dmesg)

$ sudo dmesg
...
[ 1733.994449] vboxsf: Unknown symbol vbg_warn (err -2)
[ 1733.994470] vboxsf: Unknown symbol vbg_get_gdev (err -2)
[ 1733.994492] vboxsf: Unknown symbol vbg_hgcm_connect (err -2)
[ 1733.994513] vboxsf: Unknown symbol vbg_hgcm_disconnect (err -2)
[ 1733.994527] vboxsf: Unknown symbol vbg_err (err -2)
[ 1733.994535] vboxsf: Unknown symbol vbg_status_code_to_errno (err -2)
[ 1733.994543] vboxsf: Unknown symbol vbg_put_gdev (err -2)
[ 1733.994557] vboxsf: Unknown symbol vbg_hgcm_call (err -2)
...
This task depends upon

Closed by  Christian Hesse (eworm)
Wednesday, 12 May 2021, 05:57 GMT
Reason for closing:  Not a bug
Additional comments about closing:  left-over from guest iso
Comment by Christian Hesse (eworm) - Tuesday, 11 May 2021, 19:36 GMT
With all available linux packages from official repositories the virtualbox-guest-dkms package should be unused. The linux package ships the upstream module.
Comment by Miles Whittaker (mjwhitta) - Tuesday, 11 May 2021, 19:43 GMT
Sorry. I should have clarified. I have tested both with and without virtual-guest-dkms. I have since left it uninstalled. Still get the same issues with modprobe. I imagine that package is unrelated to the error at hand.
Comment by Christian Hesse (eworm) - Tuesday, 11 May 2021, 20:00 GMT
So what linux package do you use? Looks like 'linux', which is 5.12.2.arch1-1 atm.
Comment by Miles Whittaker (mjwhitta) - Tuesday, 11 May 2021, 20:04 GMT
That is correct. I'm using the default 'linux' version 5.12.2.arch1-1.
Comment by Christian Hesse (eworm) - Tuesday, 11 May 2021, 20:52 GMT
I can successfully load the module...

root@linux ~ # modprobe vboxsf
root@linux ~ # uname -a
Linux linux 5.12.2-arch1-1 #1 SMP PREEMPT Fri, 07 May 2021 15:36:06 +0000 x86_64 GNU/Linux
root@linux ~ # lsmod | grep vboxsf
vboxsf 40960 0
vboxguest 49152 1 vboxsf
Comment by Miles Whittaker (mjwhitta) - Wednesday, 12 May 2021, 00:10 GMT
Figured it out! I've been installing guest utils from the iso for the last couple years, but when I started to have issues, I decided to switch back to this package. Obviously I was having issues with it as well, so I had assumed it was an issue with the newest version of guest utils. However, since it was working for you, I started to think maybe it was some left-over artifact from an older version... Had I installed the virtualbox-guest-utils, this wouldn't have been an issue as the package manager would have cleaned up artifacts (I think), but since I used the guest iso, I did some digging:

$ find /usr/lib/modules/5.12.2-arch1-1 -type f -exec pacman -Qo {} + 2>&1 | grep -sv "is owned by"
error: No package owns ./misc/vboxguest.ko.xz

I deleted this file (which temporarily broke guest utils even more), reinstalled "linux", and rebooted to completely fix the issue.

Apologies for wasting your time!

Loading...