Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70755 - [geeqie] image not shown

Attached to Project: Arch Linux
Opened by Gérald Rochat (grochat) - Saturday, 08 May 2021, 12:45 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 18 May 2021, 15:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

Display nothing but thumbnails ok

Additional info:
* package version(s) 1.6-4

Steps to reproduce:
Just try to display image.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 18 May 2021, 15:28 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Monday, 10 May 2021, 05:27 GMT
Is there anything shown when starting from command line? Do you have recommended optional dependencies installed?

Can you upload your picture here to check whether it's working for other users?

Please check if it has been solved already in git master (https://aur.archlinux.org/packages/geeqie-git) - if not please check
for existing or file a new upstream bug: https://github.com/BestImageViewer/geeqie/issues
Comment by Gérald Rochat (grochat) - Tuesday, 11 May 2021, 19:27 GMT
Nothing show in terminal.
All optional dependencies are installed.
It's not with one image but all images.
The problem appear in my desktop with Gnome et my laptop with Cinnamon. Also on a VM with Gnome.

The git version in AUR work great but i don't find the issue in the list.
Comment by Andreas Radke (AndyRTR) - Wednesday, 12 May 2021, 15:53 GMT
https://github.com/BestImageViewer/geeqie/commits/master - feel free to bisect your issue.

Or go with the AUR git version until a new release happens and we close this one ad "upstream".
Comment by Sibren Vasse (SibrenVasse) - Saturday, 15 May 2021, 13:23 GMT
I've bisected the issue when running geeqie (wayland - sway).
Applying https://github.com/BestImageViewer/geeqie/commit/89c5590a2ecc3132d34fa5b692d03b96e58ac117 to v1.6 fixes the issue for me.
Comment by Andreas Radke (AndyRTR) - Sunday, 16 May 2021, 10:44 GMT
Please check geeqie-1.6-6 form testing repo.
Comment by Sibren Vasse (SibrenVasse) - Sunday, 16 May 2021, 20:57 GMT
geeqie-1.6-6 works for me
Comment by Gérald Rochat (grochat) - Monday, 17 May 2021, 19:22 GMT
geeqie-1.6-6 are in extra now and work fine. Thanks.

Loading...