Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70724 - linux 5.12.1.arch1-1 i915 graphics flashing, flickering, tearing with broadwell

Attached to Project: Arch Linux
Opened by Jordan B (Xero) - Wednesday, 05 May 2021, 21:30 GMT
Last edited by Jan Alexander Steffens (heftig) - Friday, 14 May 2021, 04:28 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: thinkpad x1 carbon gen3 with broadwell cpu (i7-5600u), after updating to 5.12.1, graphics are constantly flashing / flickering with occasiona tearing on the edges

Steps to reproduce:
update to 5.12.1, reboot, graphics are in seizure mode
downgraded back to 5.11.16, everything returns to normal

I suspect this might be an upstream kernel problem, but wanted to start here first per kernel.org's bug tracking guidelines.

I tried disabling various kernel module parameters to no avail, enable_psr=0, enable_ips=0, etc. Thus far, I have not found any successful workarounds.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Friday, 14 May 2021, 04:28 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#70726 
Comment by SATO Tatsuya (tattsan) - Tuesday, 11 May 2021, 03:11 GMT
https://bugs.archlinux.org/task/70726 seems to be the same issue.
As I wrote there, REVERT the commit https://github.com/torvalds/linux/commit/2bbd6dba84d44219387df051a1c799b7bac46099 fixes the issue.
Comment by SATO Tatsuya (tattsan) - Friday, 14 May 2021, 03:57 GMT
The issue has been fixed by linux-5.12.3.arch2-1.

Loading...