Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#70705 - [python-networkx] Version conflict with python-decorator

Attached to Project: Community Packages
Opened by Blair Bonnett (bcb) - Tuesday, 04 May 2021, 10:44 GMT
Last edited by Felix Yan (felixonmars) - Saturday, 08 May 2021, 00:19 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


The package requirements currently include `decorator>=4.3,<5` (in `requirements/default.txt` and `` in the source, installed at `usr/lib/python3.9/site-packages/networkx-2.5.1-py3.9.egg-info/requires.txt`). However the Arch python-decorator packages is currently 5.0.7. This causes issues with any tools that check this metadata (one of my CLIs fails with a pkg_resources.ContextualVersionConflict exception for example).

According to decorator 5.0.7 is usable, and the pull request at changes the requirement to > 5.0.7 and looks like it will be merged for networkx 2.6.

The attached patch and updated PKGBUILD change this requirement to >5.0.7. If I build this in a clean chroot all tests pass and the resulting package makes my CLI usable again.
This task depends upon

Closed by  Felix Yan (felixonmars)
Saturday, 08 May 2021, 00:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-networkx 2.5.1-2
Comment by David Runge (dvzrv) - Friday, 07 May 2021, 18:09 GMT
This seems to become an issue with hotdoc under certain circumstances (e.g. when trying to build docs for wireplumber).