Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70704 - [qtile][chromium] Click link on dropdown list has no effect

Attached to Project: Community Packages
Opened by zhiwenzheng (zzw) - Tuesday, 04 May 2021, 08:17 GMT
Last edited by David Runge (dvzrv) - Monday, 19 July 2021, 07:58 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Evangelos Foutras (foutrelis)
David Runge (dvzrv)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Reported to chromium.org, please have a look.
https://bugs.chromium.org/p/chromium/issues/detail?id=1192979

This task depends upon

Closed by  David Runge (dvzrv)
Monday, 19 July 2021, 07:58 GMT
Reason for closing:  Upstream
Additional comments about closing:  As this is an issue for upstream to figure out, please collaborate with them to get it resolved in:
https://github.com/qtile/qtile/issues/24 04
Comment by Evangelos Foutras (foutrelis) - Tuesday, 04 May 2021, 14:57 GMT
Tried the test.html document and I can click the link without problem. Have you attempted to reproduce the issue with a new profile?
Comment by Emil (xexaxo) - Tuesday, 04 May 2021, 15:31 GMT
The test.html works like a charm and is dead-trivial html example.

Personally I'm leaning towards connection issue. Either one of:
- ISP related (the original "nothing happens", blocked service, fked DNS record, etc), or
- government related (the follow-up "The URL has been blocked as per the instructions of the Competent Government Authority in compliance to the orders of Court of Law")

There is also the minor probability of marketing/PR related since it's using "Baidu News" over any other meaningful example - google.com archlinux.org etc.
Comment by zhiwenzheng (zzw) - Tuesday, 04 May 2021, 16:11 GMT
Yes, I tried with a new profile with "--user-data-dir=/tmp/cc", that did not help.
I tried install archlinux and chromium in a virtual machine, and the test.html works fine.
I suspect some library on my filesystem corrupted, I will do a reinstallation.
Comment by zhiwenzheng (zzw) - Friday, 07 May 2021, 08:35 GMT
The issue is related to the window manager I used, which is qtile (http://www.qtile.org). If I use openbox instead, the problem disappeared.
The default configuration of qtile on archlinux is enough to reproduce the problem.
Comment by David Runge (dvzrv) - Friday, 07 May 2021, 09:03 GMT
@zzw: The default configuration is upstream's default configuration.

The relevant upstream ticket is probably: https://github.com/qtile/qtile/issues/2404

Loading...