Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70626 - [libplacebo] Initializing texture for hardware decoding failed

Attached to Project: Arch Linux
Opened by Eivind (mokkurkalve) - Wednesday, 28 April 2021, 10:28 GMT
Last edited by Levente Polyak (anthraxx) - Sunday, 09 May 2021, 09:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Playing h264 video vith mpv compiled against libplacebo 3.120.2-1 with following options
--volume-max=120 --vd-lavc-threads=8 --hwdec=auto --vo=gpu --gpu-api=vulkan --gpu-context=x11vk --profile=gpu-hq --scale=ewa_lanczossharp --cscale=ewa_lanczossharp --video-sync=display-resample --interpolation --tscale=oversample --ao=pulse
result in just a blue screen.
Downgrading libplacebo to 3.104.0-2 and compiling mpv against that makes the video play right again with same options.

These are the error messages mpv throws with libplacebo 3.120.2-1:

(+) Video --vid=1 (*) (h264 1920x1080 23.976fps)
(+) Audio --aid=1 --alang=eng (*) (opus 2ch 48000Hz)
[vo/gpu/vulkan/libplacebo] DRM modifier INTEL 0x2 not available for format r8. Ignoring, but expect possible corruption. Available modifiers:
[vo/gpu/vulkan/libplacebo] INVALID
[vo/gpu/vulkan/libplacebo] LINEAR
[vo/gpu/vulkan/libplacebo] Using legacy hacks for DMA buffers without modifiers. May result in corruption!
[ffmpeg] AVHWDeviceContext: Failed to query surface attributes: 20 (the requested function is not implemented).
[vo/gpu/vaapi-egl] failed to retrieve libavutil frame constraints
Cannot load libcuda.so.1
Using hardware decoding (vaapi).
AO: [pulse] 48000Hz stereo 2ch float
VO: [gpu] 1920x1080 vaapi[nv12]
[vo/gpu/vaapi-egl] unsupported VA image format nv12
[vo/gpu] Initializing texture for hardware decoding failed.
AV: 00:00:10 / 00:16:42 (1%) A-V: 0.004 DS: 2.500/1

The same video with libplacebo 3.104.0-2 (now working fine) :

(+) Video --vid=1 (*) (h264 1920x1080 23.976fps)
(+) Audio --aid=1 --alang=eng (*) (opus 2ch 48000Hz)
Cannot load libcuda.so.1
[ffmpeg] AVHWDeviceContext: Cannot load libcuda.so.1
[ffmpeg] AVHWDeviceContext: Could not dynamically load CUDA
Using hardware decoding (vaapi-copy).
AO: [pulse] 48000Hz stereo 2ch float
VO: [gpu] 1920x1080 nv12
AV: 00:00:17 / 00:16:42 (2%) A-V: -0.004 DS: 2.500/2


Additional info:
* package version(s)
libplacebo 3.120.2-1
mpv 1:0.33.1-2

* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Closed by  Levente Polyak (anthraxx)
Sunday, 09 May 2021, 09:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.120.3-1
Comment by Ícar N. S. (juxuanu) - Wednesday, 28 April 2021, 14:12 GMT
http://ix.io/3j4h

Same issue. I tried recompiling mpv once libplacebo was updated with the above failing result.
Comment by Levente Polyak (anthraxx) - Wednesday, 28 April 2021, 14:45 GMT
This issue should probably be reporter upstream instead, can you please do so and link the upstream issue?
Comment by loqs (loqs) - Wednesday, 28 April 2021, 21:09 GMT Comment by Eivind (mokkurkalve) - Wednesday, 28 April 2021, 22:17 GMT
Sorry, I can't post anything over at theirs. They demand a two-factor password solution using an APP on a "smart-phone" and I totally refuse to own such a "smart-phone". So it seems I can't register a user account. Sticking with my 2004 model NOKIA.
Comment by Eivind (mokkurkalve) - Thursday, 29 April 2021, 19:03 GMT
OK... The package is actually pointing at a mirror at GitHub. There I could post. The bug rapport are just a copy of this one.
https://github.com/haasn/libplacebo/issues/98
Comment by Eivind (mokkurkalve) - Tuesday, 04 May 2021, 22:44 GMT
This seems to be the end of the bug:
https://github.com/haasn/libplacebo/commit/534d43adbd0586638b47056848cddf5b660c50ad
...And in any way I can solve the problem by replacing --hwdec=auto with --hwdec=vaapi-copy
EDIT: --hwdec=vaapi doesn't seem to work on Intel UHD Graphics these days. Whether it has to do with intel-media-driver or mesa or whatnot is to complicated for me to understand.
Maybe it will start working some day?
EDIT 2: Replacing --gpu-api=vulkan --gpu-context=x11vk with --gpu-api=opengl --gpu-context=x11egl makes --hwdec=vaapi work allright. So the problem has to do with vulkan.
Well, I better change back to opengl then.


Loading...