Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70596 - [firejail] Consider adding xdg-dbus-proxy to optdepends

Attached to Project: Community Packages
Opened by helle vaanzinn (glitsj16) - Monday, 26 April 2021, 18:39 GMT
Last edited by Daniel M. Capella (polyzen) - Saturday, 21 August 2021, 04:10 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Daniel M. Capella (polyzen)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Ever since 0.9.64 firejail relies on xdg-dbus-proxy for D-Bus filtering. This major overhaul has considerable impact on the quality of the provided profiles.

RELNOTES 0.9.64
https://github.com/netblue30/firejail/blob/23ea15fd7b46845c91bfd7d5df9e9c894e940d53/RELNOTES#L53
* Fine-grained D-Bus sandboxing with xdg-dbus-proxy.
xdg-dbus-proxy must be installed, if not D-Bus access will be allowed.

Also see the discussion at https://github.com/netblue30/firejail/discussions/4216. To summarize that, Fedora requires it in its firejail.spec and Debian/Ubuntu put xdg-dbus-proxy in its Recommends array. I'm not sure if the Arch Linux packaging policy would allow it to be in depends. But at least users would be more aware of its importance if it was an optdepends.

Regards

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Closed by  Daniel M. Capella (polyzen)
Saturday, 21 August 2021, 04:10 GMT
Reason for closing:  Implemented
Additional comments about closing:  https://github.com/archlinux/svntogit-co mmunity/commit/d1a5e6832d72daa76422a745f d57a70331fc3d81#diff-3e341d2d9c67be01819 b25b25d5e53ea3cdf3a38d28846cda85a195eb9b 7203a
Comment by Daniel M. Capella (polyzen) - Wednesday, 28 April 2021, 08:47 GMT
Sergej, if you'd like a co-maintainer, please let me know!

Loading...