Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70567 - [gtest] cmake module depends on gmock

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Saturday, 24 April 2021, 10:55 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 09 May 2021, 09:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Felix Yan (felixonmars)
Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

CMake Error at /usr/lib64/cmake/GTest/GTestTargets.cmake:112 (message):
The imported target "GTest::gmock" references the file

"/usr/lib/libgmock.so.1.10.0"

but this file does not exist. Possible reasons include:

gmock has been split off from gtest, so changing 'gtest' to 'gmock'
in makedepends fixes the build.

Additional info:
* package version(s): 1.5.0-3

Steps to reproduce:
asp export chromaprint
cd chromaprint
staging-x86_64-build
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 09 May 2021, 09:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  gtest 1.10.0-6
Comment by Antonio Rojas (arojas) - Monday, 26 April 2021, 16:35 GMT
Well, the error comes from the gtest cmake config, which expects gmock to be installed. So it's gtest which should depend on gmock, which would make the split pointless. What is the reason for splitting it?
Comment by Levente Polyak (anthraxx) - Saturday, 08 May 2021, 18:54 GMT
they were traditionally even two different distinct repositories. in 2016 they got unified into one source repository but still non interwired components hence it became one split package instead of keeping it two.
after they are now hard inter wired there isn't any reason to have them split and just a historic reason.

Loading...