Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70558 - Display goes blank at end of boot on ASUS H510M-a motherboard without 'nomodeset'

Attached to Project: Arch Linux
Opened by Peter Hardman (shetland_breeder) - Friday, 23 April 2021, 15:46 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 26 April 2021, 11:44 GMT
Task Type Bug Report
Category Kernel
Status Assigned
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:

Display goes blank at end of boot on ASUS H510M-a motherboard

Linux 5.11.16.arch1.1 and linux-lts 5.10.32-1
Processor: Intel i3-10100
Intel Integrated Graphics

Unless 'nomodeset' is specified on the kernel option the display show the normal boot messages then goes blank with the monitor displaying 'No Signal.

With nomodeset the system boots to a command prompt and apart from being unable to start X everything seems normal

The attached boot journals show drm related errors at --- cut here ---



Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Comment by Peter Hardman (shetland_breeder) - Saturday, 24 April 2021, 07:25 GMT
The same SSD/cpu boots fine on a Gigabyte B460M motherboard 9currently away for replacement under warranty) so it seems it's something to do with the Rocket Lake chipset?
Comment by Peter Hardman (shetland_breeder) - Saturday, 24 April 2021, 14:41 GMT
So - I've just built a kernel from drm-tip (5.13.1000019.7a27cb7ac19a) and I can now boot into a graphics display, so it seems to be fixed upstream.

Loading...