Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70539 - system boot hang on after updating linux-lts 5.10.32-1 (with plymouth)

Attached to Project: Arch Linux
Opened by metacryptic (metacryptic) - Thursday, 22 April 2021, 08:00 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 23 April 2021, 05:11 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description
------------
system can't boot after updating kernel LTS

Steps to reproduce:
-------------------
Yesterday evening :
1) Update my linux with discover. The only package was listed was :
linux-lts 5.10.32-1
=> so have no fear for updating without waiting.
2) shut down my system

This morning :
1) boot my linux arch
2) grub ok
3) booting (plymouth is up)
=> the system hang on, nothing happen...
4) forcing reboot by pressing stop button
5) looking for warning or some bugs reported on the site archlinux.org
=> nothing martch
6) want to see message of the boot so entering in grub to edit :
suppress "splash" to see.
7) booting is ok !!!!
=> think is problem with plymouth and new kernel version. I thought that it was a crap part... but remove it is painful just turn to no splash boot...

Additional info:
-----------------
* package version(s)
system is up to date, last update is :
linux-lts 5.10.32-1

+ can't have any log

* config and/or log files etc.
plymouth with alter-logo
Operating System: Arch Linux
KDE Plasma Version: 5.21.4
KDE Frameworks Version: 5.81.0
Qt Version: 5.15.2
Kernel Version: 5.10.32-1-lts
OS Type: 64-bit
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-5250U CPU @ 1.60GHz
Memory: 7.7 Gio of RAM
Graphics Processor: Mesa Intel® HD Graphics 6000

* link to upstream bug report, if any
attach result of the command :
journalctl -b -3
(3 because retrieve a faulty boot => it ends with "Power key pressed")

This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 23 April 2021, 05:11 GMT
Reason for closing:  None
Additional comments about closing:  bug in AUR package
Comment by Andreas Radke (AndyRTR) - Thursday, 22 April 2021, 08:32 GMT
Plymouth is AUR -> not supported.

Feel free to confirm downgrading the kernel. Check the Changelog*/bisect your issue and report a kernel regression or plymouth issue upstream.
* https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.10.32
Comment by metacryptic (metacryptic) - Thursday, 22 April 2021, 09:55 GMT
If I understand well (I'm not english) :
1) Plymouth from AUR is not supported : well, nothing has been said in that direction. Or is it the new observation we can do ?
2) I haven't downgrade the kernel but I prefer to turn off the option "splash" from the boot parameter (grub). First in order to boot with editing directly grub options at the early stage of booting.
Second with "grub-customizer" suppressing the parameter "splash" to boot automatically without splash theme.
3) the thing is plymouth is a danger, it is crappy and it is a pain to remove...
4) I don't understand your comment : "bisect your issue and report a kernel regression or plymouth issue upstream."

=> Is that help ?
Comment by Andreas Radke (AndyRTR) - Thursday, 22 April 2021, 10:50 GMT
Please downgrade to the last -lts 5.10.31 kernel and confirm that it is indeed the kernel update causing your issue.

Check if 5.10.32lts works with your plymouth splash fully disabled. If it is still working you are running into a bug or setup issue with
your AUR=unsupported boot splash.

bisect=search for "git bisect" to find out the commit between the two releases that causes your bug.
Comment by metacryptic (metacryptic) - Thursday, 22 April 2021, 19:12 GMT
Thanks I understand now what you said : AUR you're right is unsupported by arch linux team.
I've just downgrade to the last kernel -lts 5.10.31 the surprise is :
=> I've the same bug, I was obliged to suppress splash in this case too...
=> Probably I've done the update before in the same day and I don't remember...

But yes I can confirm the package that cause the bug is Plymouth.
Because *without* splash, the 2 kernels are booting correctly.
Thank you

Loading...