Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70513 - [python-django] requries asgiref >= 3.3.2

Attached to Project: Arch Linux
Opened by Marcus Hoffmann (BubuIIC) - Monday, 19 April 2021, 14:11 GMT
Last edited by Jelle van der Waa (jelly) - Friday, 30 April 2021, 12:25 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jelle van der Waa (jelly)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

See: https://github.com/django/django/blob/3.2/setup.cfg#L44

When starting certain django apps it complains about a not satidfies dependency:

```
Traceback (most recent call last):
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 568, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 886, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 777, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (asgiref 3.3.1 (/usr/lib/python3.9/site-packages), Requirement.parse('asgiref<4,>=3.3.2'), {'Django', 'django'})
```

Additional info:
* package version(s) 3.2

This task depends upon

Closed by  Jelle van der Waa (jelly)
Friday, 30 April 2021, 12:25 GMT
Reason for closing:  Fixed
Comment by Marcus Hoffmann (BubuIIC) - Tuesday, 20 April 2021, 08:57 GMT
python-asgiref updated!

Loading...