Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70511 - Mutter crashs GDM and Gnome Shell with two monitors

Attached to Project: Arch Linux
Opened by Rober (rplanchuelo) - Monday, 19 April 2021, 08:56 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 04 May 2021, 11:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 12
Private No

Details

Description:

GDM and Gnome Shell can't start with two monitors (laptop + external display port)

Additional info:
* Mutter 40.0+55+gf4f82bcb9-1

Steps to reproduce:

I've just updated mutter from 40.0-3 to 40.0+55+gf4f82bcb9-1. GDM can't start with two monitors. When I unplug the external monitor, it works, but when I plug it again (display port), this screen doesn't work (image and sound).
I've do a downgrade to mutter-40.0-3, and it works.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 04 May 2021, 11:57 GMT
Reason for closing:  Fixed
Comment by Martin Sosic (Martinsos) - Monday, 19 April 2021, 19:18 GMT
Same here!
GDM can't start at all.
If I unplug monitors when booting, GDM starts ok. If I plug them in again after Gnome successfully loaded, they remain black.

The error messages (from journalctl) connected to this seem to be the following (and they keep repeating again and again, in sometimes alternating order):
```
Apr 19 20:53:59 DellArch gnome-shell[8631]: (../mutter/src/backends/native/meta-onscreen-native.c:1044):meta_onscreen_native_swap_buffers_with_damage: runtime check failed: (onscreen_native->gbm.next_fb == NULL)
Apr 19 20:53:59 DellArch gnome-shell[8631]: Failed to post KMS update: drmModeAtomicCommit: Invalid argument
Apr 19 20:53:59 DellArch gnome-shell[8631]: Page flip discarded: drmModeAtomicCommit: Invalid argument
```

EDIT: Gnome on Xorg works fine. Downgrading just mutter didn't work me -> I got different error message on boot -> actually an error screen saying that something went wrong, I believe it comes from gdm. I downgraded whole arch to 2021-04-12 and that works fine.
Comment by Neeks (neeks) - Monday, 19 April 2021, 19:49 GMT
This seems to only occur on Wayland sessions. Signing into "GNOME on Xorg" and then turning on secondary monitor works.
Comment by Vincent (vincentv) - Tuesday, 20 April 2021, 08:47 GMT
I can confirm this. And maybe related, I can now only select my native resolution for my primary screen.
Comment by Baptiste Desbiolles (Babiol) - Tuesday, 20 April 2021, 16:41 GMT
I have the same issue cannot use my secondary monitor anymore
Comment by Rober (rplanchuelo) - Tuesday, 20 April 2021, 17:21 GMT
It works if you downgrade gnome-shell and mutter
Comment by Jan Alexander Steffens (heftig) - Wednesday, 21 April 2021, 09:45 GMT
Since this is a recent regression, can you please report this with as much detail as possible at https://gitlab.gnome.org/GNOME/mutter/-/issues/ ?
Comment by Xinyu Wang (Matheritasiv) - Friday, 23 April 2021, 14:10 GMT
I don't have an extra monitor with my laptop but `gnome-shell` crashes on booting as well.
The process `gnome-shell` started by user `gdm`(PID=120) keeps reporting
```
Apr 23 21:01:34 Sarch gnome-shell[520]: meta_drm_buffer_gbm_new_lock_front failed: drmModeAddFB2WithModifiers failed: Invalid argument
```
and then recieves SIGABRT. I have tried downgrading `mutter` to `40.0-3` and `gnome-shell` to `1:40.0-1` but just recieved an error screen.
Comment by John Garland (johnnyg) - Tuesday, 27 April 2021, 09:11 GMT
Looks like someone has reported it upstream: https://gitlab.gnome.org/GNOME/mutter/-/issues/1774
Comment by John Garland (johnnyg) - Thursday, 29 April 2021, 23:35 GMT
A fix for this has been merged to mutter's master branch: https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/1843
Comment by Ben Schneider (bschnei) - Saturday, 01 May 2021, 02:17 GMT
Can confirm latest mutter package contains that patch, and this issue no longer affects me.
Comment by Rober (rplanchuelo) - Saturday, 01 May 2021, 09:04 GMT
The latest versions of mutter and gnome-shell fix the bug.

Loading...