Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70505 - Gnome Shell 40 update black wallpaper

Attached to Project: Arch Linux
Opened by swqg (swqg) - Sunday, 18 April 2021, 21:07 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 19 April 2021, 12:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
After updating to the latest gnome-shell package, the background is black and can't be changed.

Additional info:
* package version(s)
The package causing the issue:
gnome-shell-1:40.0+39+gd9e953e93-1-x86_64.pkg.tar.zst
My other packages (some are from AUR, but they shouldn't be the ones causing the issue):
chrome-gnome-shell-10.1-5-any.pkg.tar.zst
gnome-autoar-0.3.1-1-x86_64.pkg.tar.zst
gnome-backgrounds-40.0-1-any.pkg.tar.zst
gnome-backgrounds-40rc-1-any.pkg.tar.zst
gnome-bluetooth-3.34.5-1-x86_64.pkg.tar.zst
gnome-books-40.0-1-x86_64.pkg.tar.zst
gnome-boxes-40.0-1-x86_64.pkg.tar.zst
gnome-builder-3.40.0-1-x86_64.pkg.tar.zst
gnome-calculator-40.0-1-x86_64.pkg.tar.zst
gnome-calendar-3.38.2-1-x86_64.pkg.tar.zst
gnome-calendar-40.0-1-x86_64.pkg.tar.zst
gnome-characters-40.0-1-x86_64.pkg.tar.zst
gnome-chess-40.0-1-x86_64.pkg.tar.zst
gnome-chess-40.1-1-x86_64.pkg.tar.zst
gnome-clocks-40.0-1-x86_64.pkg.tar.zst
gnome-clocks-40.0-2-x86_64.pkg.tar.zst
gnome-code-assistance-2:3.16.1+14+gaad6437-1-x86_64.pkg.tar.zst
gnome-color-manager-3.36.0-1-x86_64.pkg.tar.zst
gnome-common-3.18.0-4-any.pkg.tar.zst
gnome-contacts-3.38.1-1-x86_64.pkg.tar.zst
gnome-contacts-40.0-1-x86_64.pkg.tar.zst
gnome-control-center-3.38.5-1-x86_64.pkg.tar.zst
gnome-control-center-40.0-1-x86_64.pkg.tar.zst
gnome-desktop-1:40.0-1-x86_64.pkg.tar.zst
gnome-devel-docs-40.0-1-any.pkg.tar.zst
gnome-disk-utility-40.0-1-x86_64.pkg.tar.zst
gnome-documents-3.34.0+6+g966b04ec-1-x86_64.pkg.tar.zst
gnome-font-viewer-40.0-1-x86_64.pkg.tar.zst
gnome-getting-started-docs-3.38.1-1-any.pkg.tar.zst
gnome-keyring-1:40.0-1-x86_64.pkg.tar.zst
gnome-logs-3.36.0-1-x86_64.pkg.tar.zst
gnome-maps-40.0-1-x86_64.pkg.tar.zst
gnome-menus-3.36.0-1-x86_64.pkg.tar.zst
gnome-mines-40.0-1-x86_64.pkg.tar.zst
gnome-music-1:40.0-1-x86_64.pkg.tar.zst
gnome-online-accounts-3.39.92-1-x86_64.pkg.tar.zst
gnome-photos-40.0-1-x86_64.pkg.tar.zst
gnome-remote-desktop-40.0-1-x86_64.pkg.tar.zst
gnome-robots-40.0-1-x86_64.pkg.tar.zst
gnome-screenshot-40.0-2-x86_64.pkg.tar.zst
gnome-session-40.0-1-x86_64.pkg.tar.zst
gnome-session-40beta+4+gd44888fb-1-x86_64.pkg.tar.zst
gnome-settings-daemon-40.0.1-1-x86_64.pkg.tar.zst
gnome-settings-daemon-40.0-1-x86_64.pkg.tar.zst
gnome-shell-1:3.38.4-1-x86_64.pkg.tar.zst
gnome-shell-1:40.0-1-x86_64.pkg.tar.zst
gnome-shell-1:40.0+39+gd9e953e93-1-x86_64.pkg.tar.zst
gnome-shell-extensions-40.0-1-any.pkg.tar.zst
gnome-shell-extensions-40.0-2-any.pkg.tar.zst
gnome-software-40.0-1-x86_64.pkg.tar.zst
gnome-sound-recorder-40.0-1-any.pkg.tar.zst
gnome-sudoku-40.0-1-x86_64.pkg.tar.zst
gnome-system-monitor-40.0-2-x86_64.pkg.tar.zst
gnome-terminal-3.40.0-1-x86_64.pkg.tar.zst
gnome-themes-extra-3.28-2-x86_64.pkg.tar.zst
gnome-todo-3.28.1+34+g1b5336f-1-x86_64.pkg.tar.zst
gnome-tweaks-3.34.1-1-any.pkg.tar.zst
gnome-tweaks-40.0-1-any.pkg.tar.zst
gnome-usage-3.38.1-1-x86_64.pkg.tar.zst
gnome-user-docs-40.0-1-any.pkg.tar.zst
gnome-user-share-3.34.0-2-x86_64.pkg.tar.zst
gnome-video-effects-0.5.0+4+g9554041-2-any.pkg.tar.zst
gnome-weather-3.36.1-1-any.pkg.tar.zst
gnome-weather-40.0-1-any.pkg.tar.zst
libgnome-games-support-1.8.1-1-x86_64.pkg.tar.zst


* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
1. Update to the package
2. Now your background should be black and there shouldn't be any way to change it to a different image.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 19 April 2021, 12:06 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#70504 
Comment by José Miguel Sarasola (alosarjos) - Sunday, 18 April 2021, 21:16 GMT
The issue is confirmed. https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/4138

For this gnome-shell commit to work, gjs needs to be updated too.
Comment by Ícar N. S. (juxuanu) - Sunday, 18 April 2021, 21:22 GMT
I confirm. GJS was not updated when gnome-shell landed today. It is required or the background cannot be set.

Loading...