Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70504 - [gnome-shell] Backgrounds broken since 40.0+39+gd9e953e93-1

Attached to Project: Arch Linux
Opened by Daenney (daenney) - Sunday, 18 April 2021, 20:49 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 19 April 2021, 13:12 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:

As of 40.0+39+gd9e953e93-1, backgrounds no longer work. The default Gnome background renders a solid blue, picking any other one results in a solid white background.

Package versions:
* Gnome Shell:40.0+39+gd9e953e93-1
* Mutter: 40.0+55+gf4f82bcb9-1
* Gnome Backgrounds: 40.0-1

Steps to reproduce:
* Upgrade to 40.0+39+gd9e953e93-1
* Reboot

This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 19 April 2021, 13:12 GMT
Reason for closing:  Fixed
Additional comments about closing:  gjs 1.68.0-3
Comment by R. Ouellette (rouelle) - Sunday, 18 April 2021, 21:08 GMT
I can confirm this behavior, no more backgrounds possible, the entire desktop is black. Downgrading to gnome-shell-1:40.0-1 brings back backgrounds. I allowed mutter last upgrade to mutter-40.0+55+gf4f82bcb9-1.
Comment by nya (nya) - Sunday, 18 April 2021, 21:15 GMT
I can also confirm that behavior in version 1:40.0+39+gd9e953e93-1 of gnome-shell.
Comment by sven (commonuser) - Sunday, 18 April 2021, 21:26 GMT
Same on my machine.
Comment by Sibo Dong (flyingpig) - Sunday, 18 April 2021, 21:38 GMT
From a comment on the issue filed upstream <https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/4138#note_1085366>:
> That's because 58ed969d needs gjs@ec9385b8, but Arch is shipping gjs 1.68.0.
Comment by Daenney (daenney) - Monday, 19 April 2021, 08:56 GMT
Fixed as of gjs 1.68.0-3

Loading...