Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70472 - [bpython] bpython requires python-pyxdg since 0.21

Attached to Project: Community Packages
Opened by Robin (yself) - Friday, 16 April 2021, 14:11 GMT
Last edited by Antonio Rojas (arojas) - Monday, 27 December 2021, 10:48 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Kyle Keen (keenerd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:
Since 0.21, bpython uses the external package pyxdg to look up $XDG_CONFIG_HOME.
It's a required dependency, currently missing from the PKGBUILD.

Additional info:
* link to upstream release info:
https://github.com/bpython/bpython/releases/tag/0.21-release
* link to commit:
https://github.com/bpython/bpython/commit/8bc9df74ceb1982c3bfa24ba2805783cdf9c0a06


Steps to reproduce:
1. Install bpython 0.21.
2. Execute `bpython`.
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 27 December 2021, 10:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  bpython 0.22.1-3
Comment by Rustem Bakirov (rustemb) - Thursday, 29 April 2021, 13:26 GMT
Step 1.5: Remove `python-pyxdg` if installed
Comment by David Haller (davidhaller) - Thursday, 13 May 2021, 22:47 GMT
See attached error message (traceback). bpython fails to run at all if python-pyxdg is not installed.

Loading...