Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70433 - [podman] possibly requires kata-runtime to start [needs investigation]

Attached to Project: Community Packages
Opened by Chigozirim Chukwu (FirstAirBender) - Tuesday, 13 April 2021, 21:47 GMT
Last edited by Morten Linderud (Foxboron) - Friday, 09 July 2021, 12:51 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Morten Linderud (Foxboron)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Running sudo systemctl start podman, this is the output in the logs before installing the kata-runtime`:

```
-- Journal begins at Thu 2020-11-12 10:11:29 CST, ends at Tue 2021-04-13 15:21:10 CST. --
Apr 13 12:12:29 ArcoB systemd[1]: Starting Podman API Service...
Apr 13 12:12:29 ArcoB systemd[1]: Started Podman API Service.
Apr 13 12:12:30 ArcoB podman[739769]: time="2021-04-13T12:12:30-06:00" level=info msg="/usr/bin/podman filtering at log level info"
Apr 13 12:12:30 ArcoB podman[739769]: time="2021-04-13T12:12:30-06:00" level=info msg="Not using native diff for overlay, this may cause degraded performance for building images: kernel has CONFIG_OVERLAY_FS_REDIRECT_DIR enabled"
Apr 13 12:12:30 ArcoB podman[739769]: time="2021-04-13T12:12:30-06:00" level=info msg="Error initializing configured OCI runtime kata: no valid executable found for OCI runtime kata: invalid argument"
Apr 13 12:12:30 ArcoB podman[739769]: time="2021-04-13T12:12:30-06:00" level=info msg="Found CNI network podman (type=bridge) at /etc/cni/net.d/87-podman-bridge.conflist"
Apr 13 12:12:30 ArcoB podman[739769]: time="2021-04-13T12:12:30-06:00" level=info msg="Setting parallel job count to 37"
Apr 13 12:12:30 ArcoB podman[739769]: time="2021-04-13T12:12:30-06:00" level=info msg="using systemd socket activation to determine API endpoint"
Apr 13 12:12:30 ArcoB podman[739769]: time="2021-04-13T12:12:30-06:00" level=info msg="using API endpoint: ''"
Apr 13 12:12:30 ArcoB podman[739769]: time="2021-04-13T12:12:30-06:00" level=info msg="API server listening on \"/run/podman/podman.sock\""
Apr 13 12:12:35 ArcoB systemd[1]: podman.service: Deactivated successfully.
```

here are the logs after installing group kata2-containers-bin
```
-- Journal begins at Thu 2020-11-12 10:11:29 CST, ends at Tue 2021-04-13 15:21:10 CST. --
Apr 13 14:49:11 ArcoB systemd[1]: Starting Podman API Service...
Apr 13 14:49:11 ArcoB systemd[1]: Started Podman API Service.
Apr 13 14:49:11 ArcoB podman[916556]: time="2021-04-13T14:49:11-06:00" level=info msg="/usr/bin/podman filtering at log level info"
Apr 13 14:49:11 ArcoB podman[916556]: time="2021-04-13T14:49:11-06:00" level=info msg="Not using native diff for overlay, this may cause degraded performance for building images: kernel has CONFIG_OVERLAY_FS_REDIRECT_DIR enabled"
Apr 13 14:49:11 ArcoB podman[916556]: time="2021-04-13T14:49:11-06:00" level=info msg="Found CNI network podman (type=bridge) at /etc/cni/net.d/87-podman-bridge.conflist"
Apr 13 14:49:11 ArcoB podman[916556]: time="2021-04-13T14:49:11-06:00" level=info msg="Setting parallel job count to 37"
Apr 13 14:49:11 ArcoB podman[916556]: time="2021-04-13T14:49:11-06:00" level=info msg="using systemd socket activation to determine API endpoint"
Apr 13 14:49:11 ArcoB podman[916556]: time="2021-04-13T14:49:11-06:00" level=info msg="using API endpoint: ''"
Apr 13 14:49:11 ArcoB podman[916556]: time="2021-04-13T14:49:11-06:00" level=info msg="API server listening on \"/run/podman/podman.sock\""
Apr 13 14:49:16 ArcoB systemd[1]: podman.service: Deactivated successfully.
```
This task depends upon

Closed by  Morten Linderud (Foxboron)
Friday, 09 July 2021, 12:51 GMT
Reason for closing:  Not a bug
Additional comments about closing:  You have picked an uninstalled runtime. Not a packaging issue.

Loading...