Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70429 - [unbound] sd_notify failed /run/systemd/notify: No such file or directory

Attached to Project: Community Packages
Opened by Stefan Soellner (stesoell) - Tuesday, 13 April 2021, 14:06 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 04 May 2021, 06:33 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Bruno Pagani (ArchangeGabriel)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Startup fails when unbound is chrooted outside /etc/unbound.

"fatal error: sd_notify failed /run/systemd/notify: No such file or directory. Make sure that unbound has access/permission to use the socket presented by systemd."

due to settings in unbound.service

It was fixed in:
https://bugs.archlinux.org/task/63802

unbound -V
Version 1.13.1

Thank you.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 04 May 2021, 06:33 GMT
Reason for closing:  Not a bug
Comment by Michel Koss (MichelKoss1) - Tuesday, 13 April 2021, 18:49 GMT
Do you mean you changed chroot dir by yourself? You have to adjust the systemd service then. The provided one works only with /etc/unbound and it's not possible to support arbitrary chroot path.
Comment by Stefan Soellner (stesoell) - Tuesday, 13 April 2021, 19:35 GMT
You're right. Thanks for your assistance.

Loading...