Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70425 - [hunspell-en_us] PLEASE ENTER SUMMARY

Attached to Project: Arch Linux
Opened by Eric Abrahamsen (girzel) - Monday, 12 April 2021, 18:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

My apologies if this isn't the right place for this request, or if it's already been wontfixed somewhere else, I wasn't able to find anything...

The file ./hunspell/en_US-large.aff does not include the apostrophe in the WORDCHARS setting, meaning that all software that uses this library without making any local modifications will have contractions such as "won't" marked as misspelled. (I'm using this via Emacs.)

This seems like a fairly desirable basic setting. Would you consider making that the default in the English-language libraries? Alternately, is there a clean way that I can override this locally, so I don't have to keep editing that file every time the package is updated?

Thanks!
This task depends upon

Loading...