Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70412 - [gtk3] Tests don't run properly / gtk_test_init issue

Attached to Project: Arch Linux
Opened by Senya (senya) - Sunday, 11 April 2021, 15:09 GMT
Last edited by Jan Alexander Steffens (heftig) - Sunday, 11 April 2021, 17:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Recently there was a change that added -DG_DISABLE_ASSERT to gtk3 compilation:
https://github.com/archlinux/svntogit-packages/commit/5fd8b221bd45fcaf6f6d1a09bce03b7e9c7b18aa#diff-37538beb61ff63edebbf735dfcf39e5d732f49183d6beb097169d971875ca422R38

However any (test) app that is using gtk_test_init function provided by gtk3 is broken. It outputs:
```
Tests were compiled with G_DISABLE_ASSERT and are likely no-ops. Aborting.
```

Additional info:
* package version(s)
1:3.24.28-2
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
1. Compile the following program:
```
#include <gtk/gtk.h>

int
main (int argc,
char **argv)
{
gtk_test_init (argc, argv, NULL);
return 0;
}
```

2. Run it

Expected result:

Exited with no error

Actual result:

Error:
```
Tests were compiled with G_DISABLE_ASSERT and are likely no-ops. Aborting.
```

This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Sunday, 11 April 2021, 17:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  gtk3 1:3.24.28-3
Comment by Senya (senya) - Sunday, 11 April 2021, 15:27 GMT
Also seems to be the case for gtk4 package too

Loading...