Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70386 - LXQt panel doesn't allow to select any grouped window

Attached to Project: Community Packages
Opened by Daniel Mirkin (DanielH) - Friday, 09 April 2021, 14:45 GMT
Last edited by Chih-Hsuan Yen (yan12125) - Monday, 12 April 2021, 02:01 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Antonio Rojas (arojas)
Jerome Leclanche (Adys)
Chih-Hsuan Yen (yan12125)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

I've updated my system at 2021/04/08 and 2021/04/09 and since qt5-... packages versions are +kde+subversion, LXQt panel doesn't allow to select and maximize/resize any grouped minimized window.
As example: two or more Qterminal instances in the same desktop, or Thunderbird main window and its Write window in other desktop.

Grouped windows are showed (pop up menu appears with left click) by LXQt Panel, but when I try to select one minimized window, the pop up menu dissapear.

Once all windows in the same desktop are minimized and showed in LXQt Panel, neither of them can be maximized nor resized from LXQt taskbar (Task Manager).

The only updated packages that I can see perhaps related to this bug are:
qt5-base
qt5-svg
qt5-declarative
qt5-wayland ? (I'm not using Wayland at all).
All are now "mainversion+kde+version"... Why kde?

Additional info:
* package version(s)

liblxqt 0.16.0-1
lximage-qt 0.16.0-1 (lxqt)
lxqt-about 0.16.0-1 (lxqt)
lxqt-admin 0.16.0-1 (lxqt)
lxqt-archiver 0.3.0-1 (lxqt)
lxqt-config 0.16.1-1 (lxqt)
lxqt-globalkeys 0.16.0-1 (lxqt)
lxqt-notificationd 0.16.0-1 (lxqt)
lxqt-openssh-askpass 0.16.0-1 (lxqt)
lxqt-panel 0.16.1-1 (lxqt)
lxqt-policykit 0.16.0-1 (lxqt)
lxqt-powermanagement 0.16.0-1 (lxqt)
lxqt-qtplugin 0.16.0-1 (lxqt)
lxqt-runner 0.16.0-1 (lxqt)
lxqt-session 0.16.0-1 (lxqt)
lxqt-sudo 0.16.0-1 (lxqt)
lxqt-themes 0.16.0-1 (lxqt)
obconf-qt 0.16.0-1 (lxqt)
openbox 3.6.1-7 (lxde lxde-gtk3 lxqt)
pcmanfm-qt 0.16.0-1 (lxqt)
qterminal 0.16.1-1 (lxqt)
qt5-base (5.15.2-5 -> 5.15.2+kde+r171-1)
qt5-svg (5.15.2-2 -> 5.15.2+kde+r5-1)
qt5-declarative (5.15.2-1 -> 5.15.2+kde+r24-1)
qt5-wayland (5.15.2-1 -> 5.15.2+kde+r11-1)

* config and/or log files etc.

See attached .txt

* link to upstream bug report, if any
Not found...

Steps to reproduce:

Using LXQt desktop, update qt5-base, qt5-svg, qt5-declarative and qt5-wayland to the last ...version+de+subversion.
Open two or more instances of any program in the same desktop area. Minimize one or more windows, then try to maximize or resize these minimized windows from lxqt task bar: imposible to select or access minimized windows.
This task depends upon

Closed by  Chih-Hsuan Yen (yan12125)
Monday, 12 April 2021, 02:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  lxqt-panel 0.16.1-2
Comment by Daniel Mirkin (DanielH) - Friday, 09 April 2021, 15:33 GMT
Confirmed:

Downgrading qt5-base, qt5-svg, qt5-declarative and qt5-wayland to their previous non -kde-subversion, solves this issue.

Apparently there are not issues with packages that depends on them...

I've edited my /etc/pacman.conf as
[code]
...
IgnorePkg = qt5-base qt5-declarative qt5-svg qt5-wayland
...
[/code]
until this bug were resolved by maintainers...
Comment by Antonio Rojas (arojas) - Friday, 09 April 2021, 17:58 GMT
Caused by this Qt change https://code.qt.io/cgit/qt/qtbase.git/commit/?h=5.15&id=62f86b9b7ab3421c7a74c4c05a186847c76bfb28

Can you report it upstream to lxqt? thanks.
Comment by Daniel Mirkin (DanielH) - Friday, 09 April 2021, 22:04 GMT
@arojas:
[quote]
Caused by this Qt change https://code.qt.io/cgit/qt/qtbase.git/commit/?h=5.15&id=62f86b9b7ab3421c7a74c4c05a186847c76bfb28
Can you report it upstream to lxqt? thanks.
[/quote]

Done! Issue #1972
Thanks for your quickly support!

BTW: I apologize for my lack of knowledge: why some qt5-... packages has now -kde-version? Are they forks of "official" Qt packages, taked by KDE developers?
Your reply will be welcome!
Comment by Chih-Hsuan Yen (yan12125) - Saturday, 10 April 2021, 15:58 GMT
I uploaded community-testing/lxqt-panel 0.16.1-2 with backported upstream fix. Could you check if that works for you?
Comment by Antonio Rojas (arojas) - Saturday, 10 April 2021, 16:48 GMT Comment by Daniel Mirkin (DanielH) - Sunday, 11 April 2021, 17:13 GMT

@Chih-Hsuan Yen
[quote] I uploaded community-testing/lxqt-panel 0.16.1-2 with backported upstream fix. Could you check if that works for you? [/quote]

Yes, it works for me on one of my two Arch machines.Today I'll try lxqt-panel 0.16.1-2 on my other machine, I hope that all will be OK.

I apologize for my delayed reply, I was very busy yesterday...

@arojas

Thanks you for the links, I will read the documents.

BTW: can I write to you at your email arojas@archlinux.org ? I'm argentinian and speak spanish, of course. If you have some spare time, I wish to communicate with you in our native language...
Comment by Daniel Mirkin (DanielH) - Sunday, 11 April 2021, 18:53 GMT
@Chih-Hsuan Yen

I confirm that lxqt-panel 0.16.1-2 works well on my two Arch systems.
Good job! Thanks you!
Comment by Chih-Hsuan Yen (yan12125) - Monday, 12 April 2021, 02:01 GMT
Daniel Mirkin: thanks a lot for testing on many machines! You are already quite fast in responding :)

Closing this ticket as the original issue has been fixed in Arch Linux.

Regarding keeping in touch using Spanish - there is a Spainish IRC channel (see https://wiki.archlinux.org/index.php/Arch_IRC_channels), and https://wiki.archlinux.org/index.php/International_communities may be useful, too. I'm not sure if arojas is on those places, but I bet you will find good friends there :)

Loading...