Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70338 - gnome shell does not displays windows, can't click any, alt tab not working, after starting first wi

Attached to Project: Arch Linux
Opened by Kacper Kopczyński (capsel) - Wednesday, 07 April 2021, 21:02 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 08 April 2021, 05:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:
After starting first window - shell or gnome extensions - can't click or type in any way inside any apps. Only way to see windows is to click logout - then everything waits for me to click X of their windows.

Computer is currently unusable because of that.

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
install gnome shell 40 and rest of the updates today.
This task depends upon

2021-06-12: A task closure has been requested. Reason for request: Several extensions are incompatible with Gnome 40, seems that Gnome 40 introduced several braking changes for many extensions. So, the indicated is to disable all extensions before login in, and then, update those that already has an updated version compatible with Gnome 40 and uninstall all that were not updated yet. I had those issues too, now there are many extensions that were updated and, now, I'm using Gnome 40 without any problems. For those who use dash to dock, it was abandoned in favor of dash to plank.
Comment by Kacper Kopczyński (capsel) - Wednesday, 07 April 2021, 21:24 GMT
Seems that pressing window button breaks something and alt+f2 and typing "r" helps. Not using wayland. Trying to find some logs that could help ... nothing so far.
Comment by Kacper Kopczyński (capsel) - Wednesday, 07 April 2021, 21:37 GMT
Still no logs that explain my disaster, but!

I managed to disable "windowNavigator" extension and that solved my problem... at least for now.
Comment by Kacper Kopczyński (capsel) - Wednesday, 07 April 2021, 21:48 GMT Comment by François D. (sangfroid) - Sunday, 11 April 2021, 09:39 GMT
I've the same issue, disabling WindowManager solved the problem too.
Comment by Leandro Jacques (leandro_jacques) - Sunday, 30 May 2021, 16:42 GMT
Several extensions are incompatible with Gnome 40, seems that Gnome 40 introduced several braking changes for many extensions. So, the indicated is to disable all extensions before login in, and than, update those that already has an updated version compatible with Gnome 40 and uninstall all that were not updated yet. I had those issues too, now there are many extensions that were updated and, now, I'm using Gnome 40 without any problems. For those who use dash to dock, it was abandoned in favor of dash to plank.

Loading...