Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70333 - [wezterm] should build from source rather than use appimage binaries from github

Attached to Project: Community Packages
Opened by Wez Furlong (wez) - Wednesday, 07 April 2021, 16:16 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 07 April 2021, 23:02 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When wezterm was pulled into the community packages, the `wezterm-bin` AUR was used as the base,
rather than https://aur.archlinux.org/packages/wezterm-git/

`wezterm-bin` uses binaries extracted from an AppImage that is built for an older version of debian (for maximum compatibility).
Some wezterm users have reported that running the appimage is slower than if they run `wezterm-git`.

Please consider updating the build for `wezterm` to be based upon `wezterm-git` instead of
the appimage binaries!

This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 07 April 2021, 23:02 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Wednesday, 07 April 2021, 16:39 GMT
I have no idea what you're talking about. It doesn't appear to use appimages binaries to me. https://github.com/archlinux/svntogit-community/blob/packages/wezterm/trunk/PKGBUILD
Comment by Wez Furlong (wez) - Wednesday, 07 April 2021, 18:07 GMT
ah, good!
Let's close this then!

Loading...