Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70327 - [sof-firmware] sof-hda-dsp not recognized by ALSA after upgrade from 1.6.1-1 to 1.7-1

Attached to Project: Arch Linux
Opened by tchici (tchici) - Wednesday, 07 April 2021, 03:35 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 07 April 2021, 12:55 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
sof-hda-dsp not detected after upgrading from sof-firmware 1.6.1-1 to 1.7-1. Downgrading only sof-firmare resolves the issue for now.

Additional info:
* package version(s): sof-firmware 1.7-1
* config and/or log files etc.: See upstream bug.
* link to upstream bug report, if any: https://github.com/thesofproject/sof/issues/4007

Steps to reproduce:
No steps to reproduce. Audio device is not recognized immediately after boot.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 07 April 2021, 12:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.7-2
Comment by Guido Iodice (guiodic) - Wednesday, 07 April 2021, 10:48 GMT
I confirm the bug on Intel Tiger Lake

00:1f.3 Multimedia audio controller: Intel Corporation Tiger Lake-LP Smart Sound Technology Audio Controller (rev 20)

card 1: sofhdadsp [sof-hda-dsp], device 0: HDA Analog (*) []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sofhdadsp [sof-hda-dsp], device 1: HDA Digital (*) []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sofhdadsp [sof-hda-dsp], device 3: HDMI1 (*) []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sofhdadsp [sof-hda-dsp], device 4: HDMI2 (*) []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sofhdadsp [sof-hda-dsp], device 5: HDMI3 (*) []
Subdevices: 1/1
Subdevice #0: subdevice #0
Comment by Jan Alexander Steffens (heftig) - Wednesday, 07 April 2021, 11:33 GMT
Does the firmware get loaded at all?
Comment by Jan Alexander Steffens (heftig) - Wednesday, 07 April 2021, 11:49 GMT
Should be fixed in sof-firmware 1.7-2.
Comment by tchici (tchici) - Wednesday, 07 April 2021, 12:24 GMT
Thanks. Looks like its fixed for me.

Loading...