Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70323 - [docker-compose] Allow docker-compose to use podman as container backend

Attached to Project: Community Packages
Opened by Tamwyn (Tamwyn) - Tuesday, 06 April 2021, 20:29 GMT
Last edited by Morten Linderud (Foxboron) - Tuesday, 06 April 2021, 21:09 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Since podman 3 is out it can be used as a container backend for docker-compose.
It'd be cool if either docker-compose could be installed without pulling in docker or offering a choice between docker and podman during installation.

podman-compose does exist, but it is not feature equivalent and the project in a rather desolate state, which is probably going to get worse with podman offering native compose support.
This task depends upon

Closed by  Morten Linderud (Foxboron)
Tuesday, 06 April 2021, 21:09 GMT
Reason for closing:  Not a bug
Comment by Morten Linderud (Foxboron) - Tuesday, 06 April 2021, 20:40 GMT
I think this is a duplicate of  FS#69978 . But I'll ask the same question: Why isn't the provides from `podman-docker` enough?
Comment by Tamwyn (Tamwyn) - Tuesday, 06 April 2021, 20:44 GMT
It indeed wants to achieve the same end.

As I shortly lined out, podman-compose isn't ideal. It doesn't support all features docker-compose has (realiably only up and down work for me), it has lots of open issues and pull request and in general seems to be in a rather bad shape. With the parallel efforts to make podman compatible to docker-compose its future doesn't seem bright.
Comment by Morten Linderud (Foxboron) - Tuesday, 06 April 2021, 20:54 GMT
`podman-docker`, not `podman-compose`.
Comment by Tamwyn (Tamwyn) - Tuesday, 06 April 2021, 20:59 GMT
Sorry. I missed that. Not sure why I removed that packet again, but it seems to work.
Sorry for bothering.
Comment by Morten Linderud (Foxboron) - Tuesday, 06 April 2021, 21:08 GMT
No problem!

Loading...