Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70317 - obs-studio fails with VLC media source

Attached to Project: Community Packages
Opened by Christian Wolf (christianlupus) - Tuesday, 06 April 2021, 17:01 GMT
Last edited by Jonathan Steel (jsteel) - Sunday, 30 May 2021, 09:28 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jonathan Steel (jsteel)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Adding a VLC media source (make sure that VLC is installed of course) is possible in general. When adding a file/URL to the play list, obs is killed by a segmentation fault.

When compiling manually the AUR package aur/obs-studio-browser, the VLC source is working. So, it seems to be a packaging problem to me.

Regarding the logs in gist: I just replaced the AUR package with the community package. It might be the case that additionally built filter packages (obs-vlc etc) are currently causing warning additionally.

Additional info:
* package version(s): obs-studio 26.1.2-2, vlc 3.0.12-1
* config and/or log files etc. https://gist.github.com/christianlupus/e38819d5aa6d1bd31186d56d18d7bd33

Steps to reproduce:
* Install obs-studio and vlc
* Make backup of config folder ~/.config/obs-studio
* Open obs-studio, add a scene (if not yet done)
* Add a VLC source
* Add a local file to the playlist
* Confirm the settings (which should show the VLC media stream in the OBS stream)
* Segfault gets thrown
* Any further start of OBS immediately leads to a segfault
* Restore the old configuration to allow obs to start again
This task depends upon

Closed by  Jonathan Steel (jsteel)
Sunday, 30 May 2021, 09:28 GMT
Reason for closing:  Duplicate
Additional comments about closing:  I know this one is newer but there's a bit more traction on FS#70794

Loading...