Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70226 - [file] Add detection for AVIF files

Attached to Project: Arch Linux
Opened by Noel Kuntze (thermi) - Tuesday, 30 March 2021, 10:03 GMT
Last edited by Sébastien Luttringer (seblu) - Wednesday, 31 March 2021, 19:37 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Necessary for AVIF support in gdk-pixbuf2 based image viewers, as found out here: https://github.com/AOMediaCodec/libavif/issues/569

Patch for it is attached. Patch is tested and works. It is essentially based on commit 08007ef85fd239f4ffe355e683c890a63dbf56d6
in the file git mirror (https://github.com/file/file/commit/08007ef85fd239f4ffe355e683c890a63dbf56d6), but changed to apply cleanly
on top of the version that Arch currently uses.

Steps to reproduce:
Get an image created by, for example, avifenc and try to open it in, for example, ristretto (any gdp-pixbuf2 based image viewer will do).
See that that image is not opened but skipped (ristretto), or an error message is displayed (probably any other viewer).
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Wednesday, 31 March 2021, 19:37 GMT
Reason for closing:  Implemented
Additional comments about closing:  5.40-1
Comment by loqs (loqs) - Wednesday, 31 March 2021, 16:17 GMT
@thermi can you confirm the issue is fixed in file 5.40-1 currently in testing?
Comment by Noel Kuntze (thermi) - Wednesday, 31 March 2021, 16:33 GMT
Tested and should work.
Comment by Sébastien Luttringer (seblu) - Wednesday, 31 March 2021, 18:53 GMT
Why should?
Comment by Noel Kuntze (thermi) - Wednesday, 31 March 2021, 19:12 GMT
My one setup and test can not possibly replicate any possible combination of software versions, pictures, ... .
For my one setup it works.
I can not possibly be the authority on if this works for every possible use case.
Comment by Sébastien Luttringer (seblu) - Wednesday, 31 March 2021, 19:36 GMT
Great. Thanks for testing!

Loading...