Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7021 - [xfce] default mail handler - thunar send-to I/O error

Attached to Project: Arch Linux
Opened by Ronald van Haren (pressh) - Saturday, 28 April 2007, 21:28 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 14 August 2010, 20:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version 0.8 Voodoo
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

[ronald@pressh-laptop ~]$ /usr/lib/xfce4/thunar-sendto-email /home/ronald/test
[ronald@pressh-laptop ~]$ Can't locate URI/Escape.pm in @INC (@INC contains: /usr/lib/perl5/5.8.8/i686-linux-thread-multi /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /usr/lib/xfce4/exo-compose-mail-0.3 line 26.
BEGIN failed--compilation aborted at /usr/lib/xfce4/exo-compose-mail-0.3 line 26.
Can't locate URI/Escape.pm in @INC (@INC contains: /usr/lib/perl5/5.8.8/i686-linux-thread-multi /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /usr/lib/xfce4/exo-compose-mail-0.3 line 26.
BEGIN failed--compilation aborted at /usr/lib/xfce4/exo-compose-mail-0.3 line 26.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 14 August 2010, 20:50 GMT
Reason for closing:  Not a bug
Additional comments about closing:  see comment. exo related.
Comment by Tobias Kieslich (tobias) - Sunday, 29 April 2007, 20:15 GMT
so perl-uri is a dependency not a makedepends. I'll fix that later
Comment by Stefan Liebenberg (StefanLiebenberg) - Monday, 02 August 2010, 20:00 GMT
  • Field changed: Percent Complete (100% → 0%)
I experienced this again. perl-uri isn't listed as a depedency of thunar.
Comment by Andreas Radke (AndyRTR) - Saturday, 14 August 2010, 20:49 GMT
look in your error msg:

at /usr/lib/xfce4/exo-compose-mail-0.3 line 26.

perl-uri is already an optional dependency for exo. thunar doesn't need it.

Loading...