Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70209 - Upgrade to mesa breaks lightdm login

Attached to Project: Arch Linux
Opened by Michael (ZeroBeat) - Monday, 29 March 2021, 20:06 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 04 May 2021, 12:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Laurent Carlier (lordheavy)
Maxime Gauduin (Alucryd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Upgrade to mesa 21.0.1-1 breaks lightdm login to xfce4
Login ends in a black screen with a mouse pointer.

Going back to
$ pacman -Q | grep mesa
mesa 20.3.4-3

solve the issue.

Neither lightdm.log nor Xorg.0.log showing an ERROR.

This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 04 May 2021, 12:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  see close request by op
Comment by Michael (ZeroBeat) - Monday, 29 March 2021, 20:13 GMT
Some additional information:
Removing my 20-nvidia.conf let lightdm login again into xfce4 on mesa 21.0.1-1

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "NoLogo" "1"
Option "Interactive" "False"
Option "Coolbits" "12"
EndSection

But I need to disable GPU watchdog by "Interactive" "False".
So removing this conf is not a solution.
Comment by Michael (ZeroBeat) - Tuesday, 30 March 2021, 05:54 GMT
BTW:
There are more issues, I can confirm, too, running mesa 21:
https://bugs.archlinux.org/task/70170
https://bugs.archlinux.org/task/70015
https://bugs.archlinux.org/task/70008

All of them disappear when switching back to mesa 20.3.4-3.
Comment by Michael (ZeroBeat) - Tuesday, 30 March 2021, 05:56 GMT
seat0-greeter.log showing no ERROR, too.
Comment by Michael (ZeroBeat) - Tuesday, 30 March 2021, 22:54 GMT
Running mesa 21, journalctl showing the following error:
Mär 31 00:21:11 tux1 systemd[1]: lightdm.service: Main process exited, code=exited, status=1/FAILURE
Mär 31 00:21:11 tux1 systemd[1]: lightdm.service: Failed with result 'exit-code'.
Mär 31 00:21:11 tux1 audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=lightdm comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Comment by loqs (loqs) - Wednesday, 31 March 2021, 00:11 GMT
Have you tried the suggestions from [1]?
Please post the full Xorg.0.log lightdm.log and seat0-greeter.log from a blank screen even if they do not show any errors, also lightdm.conf and the config for your greeter.

[1] https://bbs.archlinux.org/viewtopic.php?id=265009
Comment by Michael (ZeroBeat) - Wednesday, 31 March 2021, 06:19 GMT
@ loqs, thanks for sharing the link and for your effort.

Adding the files section to 20-nvidia.conf solves the issues running mesa 21

Section "Files"
ModulePath "/usr/lib/nvidia/xorg"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
Screen 0
VendorName "NVIDIA Corporation"
Option "Interactive" "False"
Option "Coolbits" "12"
EndSection

If we still need the configs and logs to be attached here, lease let me know.
For now, I'll request closure, because issue is solved.




Comment by Trevor BROOKES (Minty95) - Thursday, 01 April 2021, 09:26 GMT
I confirm this problem, updating to mesa-21.0.1-1 prevents me from logging in, am 'stuck' once I input my password and after several minutes will get just a black screen, running XFCE

Ignoring the mesa update in my pacman conf lets me update the rest of my system as normal

Trevor

Modified my /etc/X11/xorg.conf.d/20-nvidia.conf

It does not correct the problem if I install the latest mesa 21xxxxx

Section "Files"
ModulePath "/usr/lib/nvidia/xorg"
ModulePath "/usr/lib/xorg/modules"
EndSection

Loading...