Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#70197 - borgmatic requires python3 ruamel.yaml <0.17.0,>0.15.0

Attached to Project: Community Packages
Opened by Max Wölfing (ff0x) - Sunday, 28 March 2021, 18:26 GMT
Last edited by Daniel M. Capella (polyzen) - Wednesday, 31 March 2021, 06:30 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Daniel M. Capella (polyzen)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No



The latest borgmatic release (1.5.12) requires the Python3 module **ruamel.yaml** in version: <0.17.0,>0.15.0.
See also: <>

But the latest Arch upgrade replaces the package python-ruamel-yaml (0.16.13-1 -> 0.17.0-1)

The error message is:

Traceback (most recent call last):
File "/usr/bin/borgmatic", line 33, in <module>
sys.exit(load_entry_point('borgmatic==1.5.12', 'console_scripts', 'borgmatic')())
File "/usr/bin/borgmatic", line 25, in importlib_load_entry_point
return next(matches).load()
File "/usr/lib/python3.9/importlib/", line 77, in load
module = import_module('module'))
File "/usr/lib/python3.9/importlib/", line 127, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
File "<frozen importlib._bootstrap_external>", line 790, in exec_module
File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
File "/usr/lib/python3.9/site-packages/borgmatic/commands/", line 10, in <module>
import pkg_resources
File "/usr/lib/python3.9/site-packages/pkg_resources/", line 3243, in <module>
def _initialize_master_working_set():
File "/usr/lib/python3.9/site-packages/pkg_resources/", line 3226, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.9/site-packages/pkg_resources/", line 3255, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.9/site-packages/pkg_resources/", line 570, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python3.9/site-packages/pkg_resources/", line 583, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python3.9/site-packages/pkg_resources/", line 772, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'ruamel.yaml<0.17.0,>0.15.0' distribution was not found and is required by borgmatic

Arch package version: 1.5.12-4

Currently it seems there is no upstream bug open, tracking this issue.

Steps to reproduce: Try to run borgmatic.
This task depends upon

Closed by  Daniel M. Capella (polyzen)
Wednesday, 31 March 2021, 06:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  borgmatic 1.5.13-1
Comment by Dan Helfman (witten) - Monday, 29 March 2021, 03:04 GMT Comment by Sefa Eyeoglu (Scrumplex) - Tuesday, 30 March 2021, 07:56 GMT
Why does this task have a low priority?
Comment by loqs (loqs) - Tuesday, 30 March 2021, 08:14 GMT
Please try building the package with the attached PKGBUILD.diff which removes the <0.17.0 restriction for ruamel.yaml.
Comment by Bjoern Franke (bjo) - Tuesday, 30 March 2021, 12:29 GMT
Used updated PKGBUILD and borgmatic still works.
Comment by Dan Helfman (witten) - Tuesday, 30 March 2021, 22:57 GMT
This is fixed in upstream now and ruamel.yaml 0.17.x has been tested.