Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70189 - Less paging is broken when rendering colorized text

Attached to Project: Arch Linux
Opened by Johnny Halfmoon (jhalfmoon) - Saturday, 27 March 2021, 21:13 GMT
Last edited by Jan Alexander Steffens (heftig) - Monday, 29 March 2021, 00:16 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Jan Alexander Steffens (heftig)
S├ębastien Luttringer (seblu)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Yesterday a "pacman -Syu" updated the package "less" from 563-1 to 580-1 and now it completely breaks paging. When running the following example, using the pager garbles the output to the point of being useless:

ag --color test /etc | less -R

A little searching shows that less went from using upstream v5.63 to v5.80 and also from using pcre to pcre2:

25ca18cf730d (heftig 2021-03-18 16:41:43 +0000 6) pkgver=580
25ca18cf730d (heftig 2021-03-18 16:41:43 +0000 21) sh configure --prefix=/usr --sysconfdir=/etc --with-regex=pcre2

Also, less 5.80 is still in beta, as the Less homepage indicates: "less-580 has been released for BETA testing."

The bug is registered in upstream since yesterday:

https://github.com/gwsw/less/issues/140

The rationale for using release 5.80 in Arch is apparently partly described here:

https://github.com/systemd/systemd/blob/v248-rc4/NEWS#L368

It could be stated that it is a questionable decision to release a beta version of a package in core. Especially since it actually breaks functionality of that package in a big way.

A workaround is to downgrade to the previous version
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Monday, 29 March 2021, 00:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  less 1:563-1
Comment by S├ębastien Luttringer (seblu) - Sunday, 28 March 2021, 21:52 GMT
Bug is not present with less 563 with PCRE2. Bug is present with less 580 with PCRE1. So, I think the issue is not related to PCRE2.
Comment by Jan Alexander Steffens (heftig) - Sunday, 28 March 2021, 22:18 GMT
I did bisect this to the commit adding hyperlink support. https://github.com/gwsw/less/issues/140#issuecomment-808968304

Loading...