Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70178 - [mariadb] myrocks_hotbackup requires python3

Attached to Project: Arch Linux
Opened by loqs (loqs) - Friday, 26 March 2021, 18:20 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 19 June 2022, 09:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
myrocks_hotbackup is started with #!/usr/bin/env python3 since mariadb 10.5.9 [1][2] before that it was started with #!/usr/bin/env python which is also python3 on Arch.
mysql-python only provides the module MySQLdb for python2. python-mysqlclient provides the module for python3.
Either PYTHON_SHEBANG should be set to /usr/bin/env python2" and passed to cmake or mysql-python replaced by python-mysqlclient in optdepends for myrocks_hotbackup.
The latter would also also mysql-python to be dropped after  FS#65035 .

Additional info:
* mariadb 10.5.9-1
* mysql-python 1.2.5-4
[1] https://github.com/MariaDB/server/commit/2f368bb967795de5b96f21ff9d12c847df86029f
[2] https://github.com/MariaDB/server/commit/263f8aff651edf1e43e385b7390c0e67ae51d358

Steps to reproduce:
myrocks_hotbackup
Traceback (most recent call last):
File "/usr/bin/myrocks_hotbackup", line 20, in <module>
import MySQLdb
ModuleNotFoundError: No module named 'MySQLdb'
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 19 June 2022, 09:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  mariadb 10.5.10-1

Loading...