Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70134 - [semver] installs root module

Attached to Project: Community Packages
Opened by nico (nicoooo) - Tuesday, 23 March 2021, 12:20 GMT
Last edited by Felix Yan (felixonmars) - Tuesday, 23 March 2021, 16:05 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:


Additional info:
* package version(s) 7.3.5-1

Steps to reproduce:
1. Install nodejs-less
2. Install semver

error: failed to commit transaction (conflicting files)
nodejs-less: /usr/lib/node_modules/root/.travis.yml exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/LICENSE exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/README.md exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/defaults.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/index.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/.bin/network-address exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/inherits/LICENSE exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/inherits/README.md exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/inherits/inherits.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/inherits/inherits_browser.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/inherits/package.json exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/murl/README.md exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/murl/index.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/murl/package.json exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/murl/tests/index.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/murl/tests/test-match-negative.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/murl/tests/test-match-positive.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/murl/tests/test-match-strict.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/murl/tests/test-match.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/murl/tests/test-replace.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/network-address/README.md exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/network-address/cli.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/network-address/index.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/network-address/package.json exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/protein/README.md exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/protein/example.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/protein/index.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/protein/package.json exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/protein/tests/index.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/protein/tests/test-connect-compatible.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/protein/tests/test-double-mixin.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/protein/tests/test-getters-and-setters.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/protein/tests/test-no-leaks.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/protein/tests/test-prototypical.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/protein/tests/test-simple-request.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/node_modules/protein/tests/test-simple-response.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/package.json exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/index.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-body-parsers.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-errors.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-flow-control.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-fork.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-match.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-matches.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-multi-listen.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-plugins.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-random-port-cluster.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-random-port.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-rewrite.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-route-app.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-route.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-routes.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-sub-app-route.js exists in filesystem (owned by semver)
nodejs-less: /usr/lib/node_modules/root/tests/test-urls.js exists in filesystem (owned by semver)
Errors occurred, no packages were upgraded.
This task depends upon

Closed by  Felix Yan (felixonmars)
Tuesday, 23 March 2021, 16:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  semver 7.3.5-2
Comment by Water Wastage. (WaterWastage) - Tuesday, 23 March 2021, 15:26 GMT
Looks like npm doesn't recognize "--user root", ignores --user and installs "root" package (https://github.com/mafintosh/root).
Comment by Martin Rys (C0rn3j) - Tuesday, 23 March 2021, 15:26 GMT
Also seeing this with AUR/haste-server-git

EDIT: Removing --user root helped
Comment by Doug Newgard (Scimmia) - Tuesday, 23 March 2021, 15:51 GMT
Yes, there's an issue with semver, but it's not that there's a conflict with an AUR package. That package needs fixed as well.

Loading...