Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70131 - [glib2] segfaut in g_key_file_load_from_file

Attached to Project: Arch Linux
Opened by Thomas Lübking (luebking) - Monday, 22 March 2021, 23:11 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 23 March 2021, 18:45 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:

Possible cause: https://bbs.archlinux.org/viewtopic.php?pid=1963498#p1963498
The thread also has backtraces

I don't have a gitlab.gnome account and they apparently a spam issue, so they don't hand them out…
It *might* relate to the recent glib_debug=disabled build definition (but even if, the debug condition would only have stashed and possibly similar instances)
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 23 March 2021, 18:45 GMT
Reason for closing:  Fixed
Additional comments about closing:  glib2 2.68.0-4
Comment by Dennis Busch (Dennis) - Tuesday, 23 March 2021, 00:36 GMT Comment by cylgalad (cylgalad) - Tuesday, 23 March 2021, 08:02 GMT
I confirm that glib2 does segfault there when trying to launch lxde (and gtk2?) stuff like lxappearance and most annoyingly lxsession-xdg-autostart => no more autostart in lxde.
Comment by Dennis Busch (Dennis) - Tuesday, 23 March 2021, 08:19 GMT
It appears to segfault trying to read any lines like..
Name[*]=*
Comment[*]=*
..from .theme and .desktop files in folders "/usr/share/icons/","/etc/xdg/autostart" and "~/.config/autostart".

Removing all those lines and leaving only plain Name=anything and Comment=anything lines, it reads the files without crashing.
Comment by Dennis Busch (Dennis) - Tuesday, 23 March 2021, 08:30 GMT
Added a report on their bug tracker: https://gitlab.gnome.org/GNOME/glib/-/issues/2361
Comment by Thomas Lübking (luebking) - Tuesday, 23 March 2021, 08:30 GMT
Because "g_get_language_names()" is now only called "maybe" - plot thickens.
If you've a gnome gitlab account, please file a bug pointing here.
It's an obvious bug in the code and increasingly likely the cause of all the recent issues and trivially fixed… but I can't tell them (<genericgnomeattitudesucksranthere>)

Edit: thanks =)
Edit #2: can you please point them to the offending patch directly?
Comment by Dennis Busch (Dennis) - Tuesday, 23 March 2021, 08:35 GMT
Which one is the offending patch? How do I find it? (I do not have a gnome-gitlab account either, I used the button that said "login with github".)
Comment by Thomas Lübking (luebking) - Tuesday, 23 March 2021, 13:50 GMT Comment by Dennis Busch (Dennis) - Tuesday, 23 March 2021, 15:49 GMT
Thank you, I will forward your input to them. I can still see the bug(guess because I opened it), but they marked it as "confidential".
Comment by Dennis Busch (Dennis) - Tuesday, 23 March 2021, 16:13 GMT
@Thomas: Philip Withnall ( https://tecnocode.co.uk/contact/ ) says, he'll be happy to try and help you sort out getting an account on gitlab.gnome.org so that we don't have to spend time relaying messages back and forth.
Comment by Dennis Busch (Dennis) - Tuesday, 23 March 2021, 17:03 GMT
status update: A potential fix was backported to glib2 2.68, see: https://gitlab.gnome.org/GNOME/glib/-/merge_requests/2010

Loading...