Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70108 - [gvfs] admin:// location broken, "Unix process subject does not have uid set"

Attached to Project: Arch Linux
Opened by Jonathon (jonathon) - Sunday, 21 March 2021, 13:06 GMT
Last edited by Eli Schwartz (eschwartz) - Sunday, 02 May 2021, 22:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:

After the update to 1.48.0, when trying to access an admin:// location an error is thrown: "GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Unix process subject does not have uid set"

Additional info:

* Arch thread: https://bbs.archlinux.org/viewtopic.php?pid=1963191#p1963191
* Possibly related upstream report: https://gitlab.gnome.org/GNOME/gvfs/-/issues/305

Steps to reproduce:

* Update to gvfs 1.48.0
* Try to access `admin:///`
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Sunday, 02 May 2021, 22:46 GMT
Reason for closing:  Fixed
Additional comments about closing:  gvfs 1.48.1-1
Comment by Jonathon (jonathon) - Sunday, 21 March 2021, 13:58 GMT
It seems to be related to https://gitlab.gnome.org/GNOME/gvfs/-/commit/29a00938055d3c7c11533bdda3f84ec51d4cbb32 which was there to close https://gitlab.gnome.org/GNOME/gvfs/-/issues/515 ("gvfs peer-2-peer incompatible with flatpak network isolation").

Reverting just that one commit reverts the behaviour. However, this could just be a workaround and there could be some other issue that's preventing this change from working as expected, for example a lack of "named sockets":

"Let's use named sockets under /run/user/$UID/gvfsd/ instead, which will allow applications to use --filesystem=xdg-run/gvfsd to grant access."

On my system, `/run/user/$UID/gvfsd/` is empty.
Comment by Eli Schwartz (eschwartz) - Sunday, 21 March 2021, 15:23 GMT
Nice detective work!
Comment by Mark Wagie (yochananmarqos) - Thursday, 15 April 2021, 16:49 GMT Comment by Lou (loulou921222) - Sunday, 02 May 2021, 21:45 GMT
is this fixed in 1.48.1-1?
Comment by Jonathon (jonathon) - Sunday, 02 May 2021, 22:29 GMT
Seems to be fixed with 1.48.1-1. 👍

Loading...