Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70099 - [gobject-introspection] lightdm-webkit2-greeter fails to run now since gobject-introspection update

Attached to Project: Arch Linux
Opened by Arnaud Dovi (cIass101) - Sunday, 21 March 2021, 02:17 GMT
Last edited by Toolybird (Toolybird) - Sunday, 23 October 2022, 06:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

lightdm-webkit2-greeter fails to run since a dependency update of gobject-introspection w/ glib2 on sat. 20 march 2021

I don't think my report is a real bug report but instead, it all looks like a packaging issue, since a core dependency updated today. But feel free to message me if you believe this is an issue, I will create a ticket in the corresponding area

I would like to warn you that "lightdm-webkit2-greeter 2.2.5-4" is crashing on boot after updating the following dependencies sat. 20 march 2021

gobject-introspection 1.66.1-3 -> 1.68.0-1
glib2 2.66.7-1 -> 2.68.0-2

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:

* Install lightdm and lightdm-webkit2-greeter
* Configure in /etc/lightdm/lightdm.conf , [Seat:*] greeter-session=lightdm-webkit2-greeter
* Reboot
* Upon starting lightdm, a error message appear to fallback to emergency theme,

Workaround:

* Installing and enabling lightdm-gtk-greeter works
This task depends upon

Closed by  Toolybird (Toolybird)
Sunday, 23 October 2022, 06:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  webkit2gtk-2.38.1-1
Comment by Arnaud Dovi (cIass101) - Sunday, 21 March 2021, 02:32 GMT
I checked in journalctl and /var/log/lighdm/* but unfortunately, no signs of relevant errors, not much in Xorg.0.log it appears to be left untouched, so I don't think it even reaches the X11 layer.

I looks like the lightdm-webkit2-greeter is crashing without handling the error, and the only system change were the today updates gobject-introspection, glib2 and lib32-glib2
Comment by Arnaud Dovi (cIass101) - Sunday, 21 March 2021, 02:53 GMT
Found another way to workaround is to replace the default theme of the webkit2 greeter "antargos" by "litarvan" of community/lightdm-webkit-theme-litarvan

* webkit_theme = litarvan

So I'm unsure if I should have made this bug report under [gobject-introspection] but [lightdm-webkit2-greeter] instead.

Well actually, I flagged out of date lightdm-webkit2-greeter in case it requires a repackage, and this ticket in the case of any dependent app to [gobject-introspection] could require a repackage.
Comment by Antonio Rojas (arojas) - Sunday, 21 March 2021, 07:44 GMT
do not flag packages out of date unless there is a new upstream version available
Comment by Arnaud Dovi (cIass101) - Sunday, 21 March 2021, 11:16 GMT
Ok no problem will do, if you can correct this on lightdm-webkit2-greeter and lightdm-gtk-greeter
Comment by Arnaud Dovi (cIass101) - Sunday, 21 March 2021, 11:22 GMT
It seems a problems localized in the Antargos theme used in the webkit2-greeter, been using the litarvan them since yesterday without such problem.

Luckily I find this theme much more attractive than antargos

Ideally it would have to drop antargos and support a better looking them by default, in the past, I have already seen a lot of crashes of this antargos for a number of reason
Comment by Popolon (Popolon) - Sunday, 25 April 2021, 08:02 GMT
I believe the crash bug is related to Mesa that also break lxdm, instead of lightdm itself, try this patch, it resolved the issue for both those dm for me. This didn't impact gdm:

https://bugs.archlinux.org/task/70015#comment199071

Note: This patch '''is not''' included in this morning mesa-21.0.3-2 release
Comment by Arnaud Dovi (cIass101) - Sunday, 25 April 2021, 09:51 GMT
Unfortunately I'm unable to reproduce since I reinstalled my operating system to fix slow performance speed on my SSD that I think was coming from TRIM not enabled by default in LVM/LUKS.

Finally, switching the webkit2 theme, didn't help much either, instead of having the crash at every boot, I had it from time to time appearing before I reinstalled my system.

Few things I tried on my newer system

* restoring old ~/.config/gtk-3.0 (because I notice it had some deprecated settings in settings.ini like 'gtk-modules=colorreload-gtk-module:window-decorations-gtk-module'
* restoring old ~/.config/dconf/user

I have attempted to reboot multiple times, but not a single crash yet, if you found a way to reproduce, let me know, a bit difficult so without logs.

It is possible it is a theming error since the webkit2 greater is configured to report theme issues by default
Comment by Arnaud Dovi (cIass101) - Friday, 23 September 2022, 20:12 GMT
Edit: I think project is abandonned, repository is readonly, I will switch to lightdm-gtk-greeter, this one works
Hi Popolon

This time I think the whole plugin broke, neither the default theme or litarvian works after the following, I think relevant, upgrades :

[2022-09-23T19:54:12+0200] [ALPM] upgraded webkit2gtk (2.36.7-1 -> 2.38.0-2)
[2022-09-23T19:54:12+0200] [ALPM] upgraded webkit2gtk-4.1 (2.36.7-1 -> 2.38.0-2)
[2022-09-23T19:54:05+0200] [ALPM] upgraded linux (5.19.9.arch1-1 -> 5.19.10.arch1-1)
[2022-09-23T19:54:06+0200] [ALPM] upgraded linux-headers (5.19.9.arch1-1 -> 5.19.10.arch1-1)
[2022-09-23T19:54:07+0200] [ALPM] upgraded linux-zen (5.19.9.zen1-1 -> 5.19.10.zen1-1)
[2022-09-23T19:54:09+0200] [ALPM] upgraded linux-zen-docs (5.19.9.zen1-1 -> 5.19.10.zen1-1)
[2022-09-23T19:54:10+0200] [ALPM] upgraded linux-zen-headers (5.19.9.zen1-1 -> 5.19.10.zen1-1)
[2022-09-23T19:54:00+0200] [ALPM] upgraded glib2 (2.72.3-3 -> 2.74.0-1)

From the seat0-greeter.log it looks like comming from webkit2

(WebKitWebProcess:764): GLib-WARNING **: 21:19:41.410: ../glib/glib/giounix.c:412Error while getting flags for FD: Bad file descriptor (9)

(WebKitWebProcess:764): GLib-WARNING **: 21:19:41.410: Invalid file descriptor.

** (WebKitWebProcess:764): CRITICAL **: 21:19:41.715: lightdm_greeter_ensure_shared_data_dir_sync: assertion 'priv->connected' failed

It is also complaining about a permission denied about accessing /base/login



Comment by Denis Gritsenko (Shiroi_Bara) - Sunday, 25 September 2022, 00:04 GMT
Hello guys. I managed to fix it just downgrading webkit2gtk to old 2.36.7-1 version. This fixed default antergos theme. As for litarvan I uninstalled it and builded and installed aur version (https://aur.archlinux.org/packages/lightdm-webkit-theme-litarvan-git) instead. All rest packages is up today. It seems bug in webkit2gtk.
Comment by Arnaud Dovi (cIass101) - Saturday, 22 October 2022, 13:23 GMT
Hey Denis, thank you for sharing.

Fixed here.

I did not downgrade, I have been testing come updates around kernel 5.9.15 and it was still failing

And I tested today it works as before , maybe fixed in webkit2gtk 2.38.1-1 ? :)

webkit2gtk 2.38.1-1
webkit2gtk-4.1 2.38.1-1
glib2 2.74.0-2
kernel 6.0.2.arch1-1
Comment by Toolybird (Toolybird) - Sunday, 23 October 2022, 06:35 GMT
Can confirm lightdm-webkit2-greeter working again with webkit2gtk 2.38.1-1

Loading...