Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70093 - pipewire-1:0.3.24-1 and no sound

Attached to Project: Arch Linux
Opened by Antonio Corbi bellot (acorbi) - Saturday, 20 March 2021, 16:32 GMT
Last edited by Jan Alexander Steffens (heftig) - Sunday, 21 March 2021, 16:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

- Being updated to pipewire for some days and having a sound-working system, yesterday after using my computer for a while I rebooted it and completely lost sound.
- In this computer I've two sound cards:

$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
02:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]

- I usually use the ATI one to provide sound through the HDMI cable but now none of them is working.

- As I said before after I had been working for a while (sound working), rebooted the computer and it seems the software can't find any of the cards:
- "pavucontrol" int its configuration tab says "No cards available for configuration"
- "pactl info" shows this output:
Server String: /run/user/1000/pulse/native
Library Protocol Version: 34
Server Protocol Version: 34
Is Local: yes
Client Index: 38
Tile Size: 65472
User Name: acorbi
Host Name: hal9000-casa
Server Name: PulseAudio (on PipeWire 0.3.24)
Server Version: 14.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: @DEFAULT_SINK@
Default Source: @DEFAULT_SOURCE@
Cookie: b709:c254

- Please have a look at the "Default Sink" and "Default Source" outputs...it seems some variable substitution has not been made?

- I use 'sway' as my 'desktop', 'fish' as my default shell instead of bash and linux-zen as kernel.

Additional info:

* package version(s)
sway: 1:1.5.1-1
fish: 3.2.0-1
pipewire pkgs: 1:0.3.24-1
linux-zen: 5.11.7.zen1-1

* config and/or log files etc.

Relevant dmesg output:
----------------------
[ 2.658036] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:02.0/0000:02:00.1/sound/card1/input6
[ 2.658131] input: HDA ATI HDMI HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:02.0/0000:02:00.1/sound/card1/input7
[ 2.658218] input: HDA ATI HDMI HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:02.0/0000:02:00.1/sound/card1/input8
[ 2.658291] input: HDA ATI HDMI HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:02.0/0000:02:00.1/sound/card1/input9
[ 2.658349] snd_hda_codec_realtek hdaudioC0D2: autoconfig for ALC662 rev3: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[ 2.658356] snd_hda_codec_realtek hdaudioC0D2: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 2.658360] snd_hda_codec_realtek hdaudioC0D2: hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[ 2.658364] snd_hda_codec_realtek hdaudioC0D2: mono: mono_out=0x0
[ 2.658366] snd_hda_codec_realtek hdaudioC0D2: dig-out=0x1e/0x0
[ 2.658369] snd_hda_codec_realtek hdaudioC0D2: inputs:
[ 2.658370] input: HDA ATI HDMI HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:02.0/0000:02:00.1/sound/card1/input10
[ 2.658372] snd_hda_codec_realtek hdaudioC0D2: Front Mic=0x19
[ 2.658375] snd_hda_codec_realtek hdaudioC0D2: Rear Mic=0x18
[ 2.658378] snd_hda_codec_realtek hdaudioC0D2: Line=0x1a
[ 2.658471] input: HDA ATI HDMI HDMI/DP,pcm=11 as /devices/pci0000:00/0000:00:02.0/0000:02:00.1/sound/card1/input11
[ 2.676113] input: HDA Intel PCH Rear Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input12
[ 2.676197] input: HDA Intel PCH Line as /devices/pci0000:00/0000:00:1b.0/sound/card0/input13
[ 2.676284] input: HDA Intel PCH Line Out as /devices/pci0000:00/0000:00:1b.0/sound/card0/input14

* Relevant lsmod output:
------------------------
$ lsmod | grep snd
snd_hda_codec_realtek 163840 1
snd_hda_codec_generic 110592 1 snd_hda_codec_realtek
snd_hda_codec_hdmi 86016 1
ledtrig_audio 16384 1 snd_hda_codec_generic
snd_hda_intel 57344 0
snd_intel_dspcfg 28672 1 snd_hda_intel
soundwire_intel 45056 1 snd_intel_dspcfg
snd_hda_codec 184320 4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core 114688 5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hwdep 16384 1 snd_hda_codec
snd_soc_core 352256 1 soundwire_intel
snd_compress 28672 1 snd_soc_core
ac97_bus 16384 1 snd_soc_core
snd_pcm_dmaengine 16384 1 snd_soc_core
snd_pcm 163840 8 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,soundwire_intel,snd_compress,snd_soc_core,snd_hda_core,snd_pcm_dmaengine
snd_timer 45056 1 snd_pcm
snd 118784 10 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm
soundcore 16384 1 snd

This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Sunday, 21 March 2021, 16:19 GMT
Reason for closing:  Not a bug
Comment by James Conroy-Finn (jcf) - Saturday, 20 March 2021, 19:16 GMT
Rolling back to v0.3.23 of Pipewire packages has restored sound for me.

``` sh
sudo pacman -U /var/cache/pacman/pkg/pipewire-1:0.3.23-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/pipewire-alsa-1:0.3.23-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/pipewire-docs-1:0.3.23-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/pipewire-jack-1:0.3.23-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/pipewire-media-session-1:0.3.23-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/pipewire-pulse-1:0.3.23-1-x86_64.pkg.tar.zst
```
Comment by deadpyxel (deadpyxel) - Saturday, 20 March 2021, 21:53 GMT
Had the same problem and had to apply the same fix. Similar hardware:

```
linux 5.11.7.arch1-1
zsh 5.8-1
i3-gaps 4.19.1-1
pipewire 1:0.3.23-1 (after downgrade)
pipewire-pulse 1:0.3.24-1 (didn't need to downgrade, but updated same day)
pipewire-media-session 1:0.3.24-1 (same as above)
```

```sh
03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller
03:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller
```

```sh
lsmod | grep snd

snd_seq_dummy 16384 0
snd_hrtimer 16384 1
snd_seq 90112 7 snd_seq_dummy
snd_seq_device 16384 1 snd_seq
snd_hda_codec_generic 98304 1
ledtrig_audio 16384 1 snd_hda_codec_generic
snd_hda_codec_hdmi 73728 1
snd_hda_intel 57344 2
snd_intel_dspcfg 28672 1 snd_hda_intel
soundwire_intel 45056 1 snd_intel_dspcfg
snd_hda_codec 172032 3 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel
snd_hda_core 106496 4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_hwdep 16384 1 snd_hda_codec
snd_soc_core 331776 1 soundwire_intel
snd_compress 32768 1 snd_soc_core
ac97_bus 16384 1 snd_soc_core
snd_pcm_dmaengine 16384 1 snd_soc_core
snd_pcm 147456 8 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,soundwire_intel,snd_compress,snd_soc_core,snd_hda_core,snd_pcm_dmaengine
snd_timer 45056 3 snd_seq,snd_hrtimer,snd_pcm
snd 114688 17 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_compress,snd_soc_core,snd_pcm
soundcore 16384 1 snd
```

Both my `pavucontrol` and the `pactl info` where the same as yours before the downgrade
Comment by Jennings Zhang (jennydaman) - Saturday, 20 March 2021, 23:44 GMT
Popping in to say I also had issues with pipewire*-1:0.3.24-1

More specifically, the problems I have noticed were:

- No audio devices detected.
- Could not connect Bluetooth devices.
- Video playback would start after ~2 minute delay. Observed with VLC and web video players in Firefox. Opening VLC from the terminal shows that it times out waiting for audio device.

All these problems were fixed by downgrading

sudo pacman -U /var/cache/pacman/pkg/pipewire*-1:0.3.23-1-x86_64.pkg.tar.zst
Comment by Antonio Corbi bellot (acorbi) - Sunday, 21 March 2021, 12:28 GMT
Hi all!

Thanks for the suggestions.
I can confirm that by downgrading to pipewire*-1:0.3.23-1-x86_64.pkg.tar.zst sound is working again!
Comment by Morten Linderud (Foxboron) - Sunday, 21 March 2021, 12:34 GMT
Did you merge the pacnew files which was included in the new package?
Comment by Antonio Corbi bellot (acorbi) - Sunday, 21 March 2021, 13:14 GMT
Hi Morten!

"Did you merge the pacnew files which was included in the new package?": Certainly no.

How should I do that?
Comment by Morten Linderud (Foxboron) - Sunday, 21 March 2021, 13:20 GMT Comment by James Conroy-Finn (jcf) - Sunday, 21 March 2021, 14:36 GMT
I've installed the latest versions of all Pipewire packages on my system, replacing the configuration files previously installed with the newer files, and things appear to be working.

I didn't anticipate this as the cause of the issue because we're dealing with a minor point release, but with Pipewire being pre-1.0 (and assuming they're using something like SemVer), breaking changes can show up at any time.

Normally, when a `pacnew` file is generated, I'll take a look. I didn't notice the new configuration files because of some formatting issues I need to resolve with my use of Powerpill and aria2c. That's definitely on me. Apologies, and thanks for the tip, Morten!

For anyone else who comes across this issue, you might find `pacdiff` extremely helpful in catching any new configuration files you might have previously missed.

https://wiki.archlinux.org/index.php/Pacman/Pacnew_and_Pacsave#pacdiff
Comment by Antonio Corbi bellot (acorbi) - Sunday, 21 March 2021, 16:11 GMT
Hi all!

The tip by Morten also worked for me.
The problem was in the configuration, replaced /etc/pipewire/media-session.d/media-session.conf with /etc/pipewire/media-session.d/media-session.conf.pacnew and restarted pipewire.
Pipewire works again:

$ pactl info
Server String: /run/user/1000/pulse/native
Library Protocol Version: 34
Server Protocol Version: 34
Is Local: yes
Client Index: 68
Tile Size: 65472
User Name: acorbi
Host Name: hal9000-casa
Server Name: PulseAudio (on PipeWire 0.3.24)
Server Version: 14.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1b.0.pro-output-0
Default Source: alsa_input.pci-0000_00_1b.0.pro-input-0
Cookie: aee0:201a

Thanks to all.

Loading...