Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70087 - [podman] Missing podman-plugin leads to degraded `docker-compose` support

Attached to Project: Community Packages
Opened by Tilman (gilbus_) - Saturday, 20 March 2021, 11:40 GMT
Last edited by Morten Linderud (Foxboron) - Monday, 29 March 2021, 17:27 GMT
Task Type General Gripe
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Morten Linderud (Foxboron)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Podman 3.0 recently introduced support for `docker-compose` but without the `dnsname` pluginĀ¹
it is not possible to resolve containers by their name leading to errors such as
https://github.com/containers/podman/issues/9292. Fedora does offer a dedicated `podman-plugins` packageĀ²
but archlinux does not which i would like to address with this issue. So far, archlinux package maintainers do not seem
to package any plugins at all since the default path in `/etc/containers/container.conf:241` (`/usr/libexec/cni`)
does not exist.

Since it does also lead to degraded functionality it's not purely a feature request IMHO.

[1]: https://github.com/containers/dnsname
[2]: https://src.fedoraproject.org/rpms/podman/blob/rawhide/f/podman.spec#_37

Additional info:
* podman 3.0.1-2
* https://github.com/containers/podman/issues/9292

Steps to reproduce:

* follow steps in linked bug report

Thanks for your hard work!
This task depends upon

Closed by  Morten Linderud (Foxboron)
Monday, 29 March 2021, 17:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  podman-dnsname is not packaged
Comment by Morten Linderud (Foxboron) - Monday, 22 March 2021, 23:33 GMT
>So far, archlinux package maintainers do not seem to package any plugins at all since the default path in `/etc/containers/container.conf:241` (`/usr/libexec/cni`) does not exist.

Incorrrect, the lookup path is `/opt/cni/bin` unless specified in the config. Which should say `/usr/lib/cni` granted. There are 18 plugins provided by `cni-plugins`.


Anyhow!

`podman-dnsname` has been packaged. Please test and ensure it works for you :) Thanks!

https://archlinux.org/packages/community/x86_64/podman-dnsname/

Loading...