Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70086 - systemd-248rc4-1 and systemd-resolved problems

Attached to Project: Arch Linux
Opened by Antonio Corbi bellot (acorbi) - Saturday, 20 March 2021, 11:22 GMT
Last edited by Christian Hesse (eworm) - Sunday, 21 March 2021, 20:03 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After updating to systemd-248rc4-1 I've problems trying to watch some youtube videos (videos from outside of my country: Spain), i.e. https://youtu.be/618uCFTNNpE. It doesn't happen with videos from channels created by spanish people...so I thought it somehow was related to dns.

The problem I observe with the videos from outside Spain is that I get the yt spinning wheel going on and on and some times after reloading the page I can finally watch the video but with problems.

If I edit /etc/nsswitch.conf, place "dns" before "resolve" and restart systemd-resolved I can finally watch all the videos without problems

This didn't happen with systemd 247.4-2.

Additional info:
* package version(s)

systemctl --version
systemd 248 (248rc4-1-arch)
+PAM +AUDIT -SELINUX -APPARMOR -IMA +SMACK +SECCOMP +GCRYPT +GNUTLS +OPENSSL +ACL +BLKID +CURL +ELFUTILS -FIDO2 +IDN2 -IDN +IPTC +KMOD +LIBCRYPTSETUP +LIBFDISK +PCRE2 -PWQUALITY +P11KIT -QRENCODE +BZIP2 +LZ4 +XZ +ZLIB +ZSTD +XKBCOMMON +UTMP -SYSVINIT default-hierarchy=unified

This task depends upon

Closed by  Christian Hesse (eworm)
Sunday, 21 March 2021, 20:03 GMT
Reason for closing:  Works for me
Additional comments about closing:  pipewire issue  FS#70093 
Comment by Antonio Corbi bellot (acorbi) - Sunday, 21 March 2021, 12:33 GMT
An update in order to close this bug.

I've also opened bug  FS#70093  related to pipewire and no sound...well in one of the comments received one user said this:

"- Video playback would start after ~2 minute delay. Observed with VLC and web video players in Firefox. Opening VLC from the terminal shows that it times out waiting for audio device.!"

And I can confirm that what I thought where problems related to dns solving are in fact due to pipewire.
Downgrading pipewire makes youtube videos play and sound as they should.

Sorry for the noise.
Comment by Christian Hesse (eworm) - Sunday, 21 March 2021, 20:00 GMT
Thanks for feedback and clarification!

Loading...