Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69978 - [docker-compose] Depends on docker when podman also provides docker.sock

Attached to Project: Community Packages
Opened by Jaakko Sirén (Jaakkonen) - Saturday, 13 March 2021, 18:12 GMT
Last edited by Morten Linderud (Foxboron) - Wednesday, 17 March 2021, 22:47 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Andrew Crerar (andrewSC)
Morten Linderud (Foxboron)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Docker-compose depends on `docker` package and not on docker.socket which is also provided by `podman`.

Additional info:
* Podman version 3.0.1-2
* Docker-compose version 1.28.5-1
* docker version 1:20.10.5-1

Steps to reproduce:
Install `podman`, enable `podman.socket` with systemctl, install `docker-compose`

Now `docker` gets installed even though `/var/run/docker.sock` is already offered by `podman.socket`.

Info on using podman for docker.sock: https://www.redhat.com/sysadmin/podman-docker-compose

I suggest adding "provides" `docker.sock` to podman and docker, and make docker-compose depend on that :)
This task depends upon

Closed by  Morten Linderud (Foxboron)
Wednesday, 17 March 2021, 22:47 GMT
Reason for closing:  Not a bug
Additional comments about closing:  If you want to replace docker with podman, install podman-docker.
Comment by Jaakko Sirén (Jaakkonen) - Saturday, 13 March 2021, 18:24 GMT
This seems to require a bit of work on `podman` package too. Unlike fedora/redhat distros, on Arch `podman.socket` systemd unit does not create `/var/run/docker.sock` but instead creates `/run/podman/podman.sock`. Maybe fix this by editing the `podman.socket` unit to create that same file under `/var/run` as `docker.socket` does.
Comment by Morten Linderud (Foxboron) - Saturday, 13 March 2021, 23:18 GMT
Why isn't the provides from `podman-docker` enough?

Loading...