Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69949 - [grub] doesn't detect windows anymore

Attached to Project: Arch Linux
Opened by Ionut Biru (wonder) - Thursday, 11 March 2021, 21:37 GMT
Last edited by Christian Hesse (eworm) - Friday, 12 March 2021, 10:55 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Ronald van Haren (pressh)
Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After upgrading grub from testing to version grub-2:2.04.r358.g39cfb3eb5-2, grub-mkconfig doesn't detect windows anymore.

Downgrading to core version grub 2:2.04-10 fixes the problem.

Steps to reproduce:
upgrade to grub-2:2.04.r358.g39cfb3eb5-2

grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux.img
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check v documentation entry.
Adding boot menu entry for UEFI Firmware Settings ...
done



downgrading to grub-2:2.04-10
grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux.img
Found Windows Boot Manager on /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
done


I believe with grub-2:2.04.r358.g39cfb3eb5-2 GRUB_DISABLE_OS_PROBER is true by default.
After adding in /etc/default/grub GRUB_DISALE_OS_PROBER=false the output is:

grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux.img
Warning: os-prober will be executed to detect other bootable partitions.
It's output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings ...
done
This task depends upon

Closed by  Christian Hesse (eworm)
Friday, 12 March 2021, 10:55 GMT
Reason for closing:  Not a bug
Additional comments about closing:  intended behavior
Comment by Morten Linderud (Foxboron) - Thursday, 11 March 2021, 22:00 GMT
This is intentional and part of the upstream changes after the Grub embargo that was released in the start of this month.

https://lists.gnu.org/archive/html/grub-devel/2021-03/msg00120.html

This isn't really a bug and more a documentation issue. But I think the variable is going to be renamed.
Comment by Christian Hesse (eworm) - Friday, 12 March 2021, 06:47 GMT
This is intentional, and our package will not change it.
However the message should read:

Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.

Did it really show a "v" instead of the real variable name for you?
Comment by Ionut Biru (wonder) - Friday, 12 March 2021, 10:43 GMT
I think it was a typo in my end. Feel free to close the bug as not a bug.

Loading...