Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69925 - [syncthing-relaysrv] Can't listen to the port

Attached to Project: Community Packages
Opened by dwxh (dwxh) - Tuesday, 09 March 2021, 15:53 GMT
Last edited by Jaroslav Lichtblau (Dragonlord) - Sunday, 12 September 2021, 11:15 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jaroslav Lichtblau (Dragonlord)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

This version can't listen to the target port! (22067)

Additional info:
* package version(s) :1.14.0-1
* config and/or log files etc : nothing, even regenernate the key and cert also can't.

Steps to reproduce:

Just install the new package and start it, in `ss -ntlp` command, it don't take the ports, even if add the ports in args!
version 1.13.1-1 and before can work, don't update it.
This task depends upon

Closed by  Jaroslav Lichtblau (Dragonlord)
Sunday, 12 September 2021, 11:15 GMT
Reason for closing:  Upstream
Additional comments about closing:  Fixed upstream
Comment by John Sivak (jsivak) - Wednesday, 10 March 2021, 14:59 GMT
I am seeing this behavior as well. Downgrading to 1.31.1-1 is my work-around.

Let me know if there is anything I can do to test/provide more details.
Comment by Spyros Stathopoulos (Foucault) - Friday, 12 March 2021, 00:40 GMT
I have the same problem. After doing a quick bisect it looks like the first problematic commit is f63cdbfcfa76a781693ae04ee5b4dae2c7bbf0f2. Everything before that works. This is most likely an upstream issue.

Edit: Yeap it's been reported upstream and fixed already: https://github.com/syncthing/syncthing/issues/7451.
Comment by Michael Clark (Iiridayn) - Sunday, 04 April 2021, 01:50 GMT
Ah, glad I found this, just spent a couple hours tracking down what was wrong. Been long enough, seems the maintainer isn't getting notifications of issues. Used `pacman -U https://archive.archlinux.org/packages/s/syncthing-relaysrv/syncthing-relaysrv-1.13.1-1-x86_64.pkg.tar.zst` to downgrade.

Loading...