Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69912 - [typescript] [npm-check-updates] package includes /usr/lib/node_modules/root/

Attached to Project: Community Packages
Opened by Johannes Wienke (languitar) - Monday, 08 March 2021, 09:06 GMT
Last edited by Felix Yan (felixonmars) - Tuesday, 09 March 2021, 13:07 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

The current typescript package 4.2.3-1 includes a folder /usr/lib/node_modules/root/. This seems to happen since an upstream change to node or npm as one of my packages was also affected and included the exact same files. Therefore, the potential for conflicts is very high an these files shouldn't exist in the package in any case.

Additional info:
* package version(s): 4.2.3-1

Steps to reproduce:

❯ pacman -Qo /usr/lib/node_modules/root/
/usr/lib/node_modules/root/ is owned by typescript 4.2.
This task depends upon

Closed by  Felix Yan (felixonmars)
Tuesday, 09 March 2021, 13:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  typescript 4.2.3-2
npm-check-updates 11.2.0-1
Comment by Doug Newgard (Scimmia) - Monday, 08 March 2021, 16:06 GMT
There seems to be a serious issue with the tooling here, any PKGBUILD using `npm install --user root` appears to have this problem when it gets rebuilt/updated.
Comment by Johannes Wienke (languitar) - Monday, 08 March 2021, 18:07 GMT
Yes, my AUR package was also affected. I could work around that after removing the user flag
Comment by Johannes Wienke (languitar) - Monday, 08 March 2021, 18:09 GMT Comment by Doug Newgard (Scimmia) - Monday, 08 March 2021, 18:21 GMT

Loading...