Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69906 - [elasticsearch] Existing /var/lib/elasticsearch causes installation to fail

Attached to Project: Community Packages
Opened by Randy Fin (oversla) - Sunday, 07 March 2021, 21:00 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 28 June 2021, 21:35 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Because /var/lib/elasticsearch is listed in the package contents, you can't install elasticsearch when the database already exists, such as when you're using a database you backed up earlier. You get an error "failed to commit transaction (conflicting files)".

If you look at the package contents for packages like redis and postgresql, they don't include anything under /var/lib. This allows them to be installed fresh but with existing data directories.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 28 June 2021, 21:35 GMT
Reason for closing:  Not a bug
Comment by Eli Schwartz (eschwartz) - Monday, 28 June 2021, 21:35 GMT
> You get an error "failed to commit transaction (conflicting files)".

This is completely false and the bug report makes no sense. The only "file" in the package within /var/lib is a directory. Directories are not checked for file conflicts, and if they were then Arch would be in major trouble due to conflicts on e.g. /usr/bin /usr/lib in 99% of packages.

Loading...