Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69903 - [kodi-x11] PLEASE ENTER SUMMARY

Attached to Project: Community Packages
Opened by Keith Patton (kaipee) - Sunday, 07 March 2021, 14:12 GMT
Last edited by Ike Devolder (BlackEagle) - Sunday, 28 March 2021, 11:43 GMT
Task Type General Gripe
Category Packages
Status Closed
Assigned To Ike Devolder (BlackEagle)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Installing kodi-x11 (or performing a system upgrade) over an existing installation with kodi v18 causes the following error to halt installation/upgrade:

:: installing kodi-x11 (19.0-9) breaks dependency 'KODI-BIN' required by kodi

Steps to reproduce:
1. Have kodi (v18) installed
2. Upgrade kodi
This task depends upon

Closed by  Ike Devolder (BlackEagle)
Sunday, 28 March 2021, 11:43 GMT
Reason for closing:  No response
Comment by Ike Devolder (BlackEagle) - Sunday, 07 March 2021, 18:00 GMT
Could you provide more details because this was tested multiple times

What is the exact command you executed to upgrade kodi-x11?
Comment by Keith Patton (kaipee) - Sunday, 07 March 2021, 23:09 GMT
sudo pacman -Syyu
Comment by Keith Patton (kaipee) - Sunday, 07 March 2021, 23:10 GMT
Removing kodi and explicitly installing kodi-x11 works.
Comment by Ike Devolder (BlackEagle) - Monday, 08 March 2021, 08:09 GMT
I don't understand because kodi-x11 now provides and replaces 'kodi' so it should have updated just fine, unless the mirror or database you were using still had the kodi package (18.9) there
Comment by Keith Patton (kaipee) - Monday, 08 March 2021, 10:54 GMT
The issue was apparent on both desktop and laptop which had kodi installed.
Comment by Doug Newgard (Scimmia) - Monday, 08 March 2021, 13:09 GMT
Are you running with --noconfirm or something? Or did it ask if you wanted to replace the package and you said no (default)?

Loading...