Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69902 - qt5-webengine-5.15.3-2 breaks mail rendering in kmail-20.12.3-1

Attached to Project: Arch Linux
Opened by Urs Joss (ursus) - Sunday, 07 March 2021, 11:45 GMT
Last edited by Antonio Rojas (arojas) - Friday, 12 March 2021, 12:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 13
Private No

Details

Description:

This morning's upgrade of qt-webengine from 5.15.2-5 to 5.15.3-2 prevents kmail from displaying the content of an email.

Downgrading to 5.15.2-5 fixes it for now. OC it's not clear to me if kmail and/or qt-webengine will have to receive a fix to make the combination of the two packages work correctly.

Steps to reproduce:
- Ensure you have qt-webengine-5.15.2-5 and kmail installed. Open kmail and enjoy it displaying your mail. Close kmail
- pacman -Syu to upgrade qt-webengine to 5.15.3-2
- Open kmail again. You'll still see the list of email, but you will not see the email content.
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 12 March 2021, 12:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  qt5-webengine 5.15.3-3
Comment by Urs Joss (ursus) - Sunday, 07 March 2021, 11:46 GMT
Probably should have severity High, sorry.
Comment by Urs Joss (ursus) - Sunday, 07 March 2021, 12:08 GMT
When opening kmail from konsole, it keeps logging the following error

[39156:39156:0307/130739.895761:ERROR:network_service_instance_impl.cc(286)] Network service crashed, restarting service.
Comment by Antonio Rojas (arojas) - Sunday, 07 March 2021, 13:20 GMT
Can't reproduce it. How are you connecting to the network? Does it also happen with other webengine browsers (qutebrowser, falkon, konqueror)?
Comment by Antonio Rojas (arojas) - Sunday, 07 March 2021, 13:22 GMT
Also, make sure to actually close kmail between steps (1) and (3). Just clicking the close button won't close the application, it will stay hidden in the system tray.
Comment by Urs Joss (ursus) - Sunday, 07 March 2021, 13:54 GMT
The kmail process was gone for sure (I checked with pgrep). I had this issue with two machines. I'll investigate a bit more
Comment by Urs Joss (ursus) - Sunday, 07 March 2021, 13:59 GMT
Same issue with qutebrowser and falkon, but not with konqueror.
Comment by Antonio Rojas (arojas) - Sunday, 07 March 2021, 14:04 GMT
How are you connecting to the network?
Comment by Urs Joss (ursus) - Sunday, 07 March 2021, 14:06 GMT
Not sure what to tell you about the network connection. It's a wired connect (RJ45), I have NetworkManager installed. The plasma tray network applet shows me both the wired connection and some WLANs. What information is useful for you?
Comment by Urs Joss (ursus) - Sunday, 07 March 2021, 14:07 GMT
ps -ef | grep -i network
root 595 1 0 Mär06 ? 00:00:29 /usr/bin/NetworkManager --no-daemon
dhcpcd 604 601 0 Mär06 ? 00:00:00 dhcpcd: [network proxy]
urs 45069 45036 0 14:55 ? 00:00:00 /usr/lib/qt/libexec/QtWebEngineProcess --type=utility --enable-features=AllowContentInitiatedDataUrlNavigations,TracingServiceInProcess --disable-features=BackgroundFetch,ConsolidatedMovementXY,DnsOverHttpsUpgrade,FontSrcLocalMatching,FormControlsRefresh,MojoVideoCapture,PictureInPicture,SmsReceiver,UseSkiaRenderer,WebPayments,WebUSB --lang=de-CH --service-sandbox-type=network --use-gl=desktop --application-name=konqueror --webengine-schemes=error:lL;konq:lL;man:lL;info:lL;ms-its:lL;ghelp:lL;perldoc:lL;help:lL;about:lL;qrc:sLV --shared-files
urs 47784 1326 3 15:03 ? 00:00:01 /usr/bin/systemsettings5 kcm_networkmanagement
Comment by Urs Joss (ursus) - Sunday, 07 March 2021, 14:09 GMT
Ok, got me there: Same issue with konqueror. That one was still open from before the upgrade.
Comment by Urs Joss (ursus) - Sunday, 07 March 2021, 14:27 GMT
Confusing the hell out of me: network_service_instance seems to be a chromium topic (sometimes reported even on Windoze). The error thrown is this one:
https://chromium.googlesource.com/chromium/src/+/master/content/browser/network_service_instance_impl.cc#330

I uninstalled chromium, even rebooted and still get the issue. How is qt5_webengine connected to chromium?
Comment by Urs Joss (ursus) - Sunday, 07 March 2021, 14:32 GMT
Didn't know that qt5_webengine is actually based on chromium... (https://doc.qt.io/qt-5/qtwebengine-overview.html#qt-webengine-core-module)
Comment by Urs Joss (ursus) - Sunday, 07 March 2021, 14:35 GMT
I have both X11 and wayland installed. The problem occurs with whichever I start plasma.
Comment by Robert (robson) - Sunday, 07 March 2021, 15:43 GMT
Same thing with ClipGrab, it stopped working.
Comment by Antonio Rojas (arojas) - Sunday, 07 March 2021, 16:50 GMT
@robson please give more details. It stopped working how?
Comment by Urs Joss (ursus) - Sunday, 07 March 2021, 16:59 GMT
starting ClipGrab from konsole with qt5-webengine-5.15.3-2 installed yields the same log output:

[15968:15968:0307/175708.255571:ERROR:network_service_instance_impl.cc(286)] Network service crashed, restarting service.

With qt5-webengine-5.15.2-5 it works as expected.
Comment by Antonio Rojas (arojas) - Sunday, 07 March 2021, 17:08 GMT
@ursus yes, it's clear by now that webengine is broken on your system. I'm trying to know if robson's issue is the same one, and then we'd need to find what do your systems have in common.
Comment by Robert (robson) - Sunday, 07 March 2021, 17:22 GMT
I'm using Xfce4, and here is ClipGrab screen
https://i.postimg.cc/KjsVdgwQ/Przechwycenie-obrazu-ekranu-2021-03-07-18-19-21.png
And running ClipGrab from a terminal gives this result
[12784:12784:0307/183259.214865:ERROR:network_service_instance_impl.cc(286)] Network service crashed, restarting service.
Comment by Simon (Begler) - Sunday, 07 March 2021, 17:29 GMT
Same issue with Anki. Dowgrading fixes it. The application starts but with no content in the window except for the menu. And I get the same error message as ursus.

Not sure what information would be useful. My laptop is a Thinkpad X1C6. I'm using VPN with OpenVPN or Wireguard, but closing the connection doesn't make a difference.

KDE System Information:

Operating System: Arch Linux
KDE Plasma Version: 5.21.2
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2
Kernel Version: 5.10.20-1-lts
OS Type: 64-bit
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-8650U CPU @ 1.90GHz
Memory: 15,4 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
Comment by Urs Joss (ursus) - Sunday, 07 March 2021, 17:56 GMT
For what it's worth (neofetch --off):
OS: Arch Linux x86_64
Host: Precision 7520
Kernel: 5.11.2-arch1-1
Uptime: 3 hours, 34 mins
Packages: 1960 (pacman)
Shell: fish 3.1.2
Resolution: 1920x1200
DE: Plasma
WM: kwin
Theme: Breeze Light [Plasma], Breeze [GTK2/3]
Icons: breeze [Plasma], breeze [GTK2/3]
Terminal: konsole
CPU: Intel i7-7700HQ (8) @ 3.800GHz
GPU: Intel HD Graphics 630
Memory: 2988MiB / 31938MiB
Comment by Robert (robson) - Sunday, 07 March 2021, 18:02 GMT Comment by Antonio Rojas (arojas) - Sunday, 07 March 2021, 18:10 GMT
Any related dump in coredumpctl?
Comment by Simon (Begler) - Sunday, 07 March 2021, 18:26 GMT
Nothing related in coredumpctl for me
Comment by Han PuYu (drllpiao) - Monday, 08 March 2021, 04:55 GMT
I have the same issue. Reproduced on two Gentoo Linux system and one Archlinux system.

This is my report on Gentoo Linux: https://bugs.gentoo.org/773919

more detail: https://github.com/12101111/overlay/issues/13

a workaround: run qtwebengine with --single-process

This workaround has a limit: many programs have their own command line praser, e.g.: konqueror: Unknown option 'single-process'.
Comment by Antonio Rojas (arojas) - Monday, 08 March 2021, 07:14 GMT
@drllpiao since you seem to have investigated the issue in detail, could you please report it upstream? Thanks.
Comment by Florian Bruhin (The-Compiler) - Monday, 08 March 2021, 22:25 GMT
It'd be interesting to know what window manager affected people are using. From the information I've gathered[1] so far, all people affected by this are either on i3wm or bspwm (yet [2] mentions seeing it on KDE Plasma, while someone in the qutebrowser repository said they could only reproduce after switching from Plasma to i3).

[1] https://github.com/qutebrowser/qutebrowser/issues/6235#issuecomment-793099273
[2] https://github.com/12101111/overlay/issues/13#issuecomment-792458441
Comment by Florian Bruhin (The-Compiler) - Monday, 08 March 2021, 22:26 GMT
Sorry, most of you already mentioned this above (and it seems to be Plasma for most) - I should probably go to bed and continue debugging this tomorrow.
Comment by Walter Casanova (wcasanova) - Tuesday, 09 March 2021, 01:15 GMT
same error, other apps like falkon and psi+, same if i run kmail from terminal.

Connection to speech-dispatcher failed
Cannot initialize model with data QJsonObject() . missing: QJsonValue(string, "urls")
[185197:185197:0308/220938.475866:ERROR:network_service_instance_impl.cc(286)] Network service crashed, restarting service.
Comment by Outvi V (outloudvi) - Tuesday, 09 March 2021, 05:50 GMT
Reporting that Calibre 5.12.0-1 is also broken on EPUB reading. It's fixed by downgrading qt5-webengine to 5.15.2-5.

Prominent error logs:

[18785:18785:0309/132409.836444:ERROR:network_service_instance_impl.cc(286)] Network service crashed, restarting service.
The Qt WebEngine Render process crashed with termination type: -1 and exit code: 1002
Comment by Florian Bruhin (The-Compiler) - Tuesday, 09 March 2021, 19:53 GMT
I think this might be related to the locale somehow. With my default LANG=en_US.UTF-8 I can't reproduce, but with LANG=en_DK.UTF-8 I can.

Will dig into it more tomorrow or so.
Comment by Simon (Begler) - Tuesday, 09 March 2021, 22:31 GMT
Interesting find. My locale is en_DK.UTF-8.
Comment by Urs Joss (ursus) - Wednesday, 10 March 2021, 02:58 GMT
@The-Compiler you're on to something here. My locale is de_CH.UTF-8.

With qt5-webengine-5.15.3-2 installed, starting e.g. kmail from konsole with

LANG=en_US.UTF-8 kmail

works successfully, while

LANG=de_CH.UTF-8 kmail

shows the faulty behavior.
Comment by Florian Bruhin (The-Compiler) - Wednesday, 10 March 2021, 12:31 GMT
FYI, I now reported this upstream: https://bugreports.qt.io/browse/QTBUG-91715

I found a better workaround (--single-process is bad from a stability/security perspective):

* Find out the locale .pak name matching your locale in /usr/share/qt/translations/qtwebengine_locales/ - this is usually the first part of your locale, except for en_DK.UTF-8 (or other en_* except en_US and en_GB) where you'll need to pick either "en-GB" or "en-US". Other special cases might be es-419, pt-BR, pt-PT, zh-CN and zh-TW.
* Start the affected application with the according --lang argument, e.g. --lang=de
* If your application doesn't accept/forward those arguments, set QTWEBENGINE_CHROMIUM_FLAGS=--lang=de in your environment instead (for qutebrowser, use --qt-flag or its qt.args setting)

@ursus Greetings from Rüti ZH (near Rapperswil) :)
Comment by Han PuYu (drllpiao) - Wednesday, 10 March 2021, 17:34 GMT Comment by Florian Bruhin (The-Compiler) - Thursday, 11 March 2021, 09:54 GMT
FWIW the patch still has issues - it causes a crash for me (without problems before) and for someone else too, see the comments on the review page. I'd recommend waiting until it's been fixed and merged upstream.
Comment by Sergio Tridente (TioDuke) - Friday, 12 March 2021, 03:06 GMT
Same here with akregator on a fully Plasma desktop with LANG=en_CA.UTF8
Comment by Sergio Tridente (TioDuke) - Friday, 12 March 2021, 03:14 GMT
Another workaround: I just tried symlinking en-US.pak to en-CA.pak on /usr/share/qt/translations/qtwebengine_locales and it worked!!

Loading...