Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#69900 - [linux-xxx/intel-ucode]Frequent early freezes during boot when switching from efifb0 to tty0

Attached to Project: Arch Linux
Opened by Andrea Amorosi (AndreaA) - Saturday, 06 March 2021, 23:12 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 19 September 2021, 08:38 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Andreas Radke (AndyRTR)
Jan Alexander Steffens (heftig)
Christian Hesse (eworm)
Levente Polyak (anthraxx)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


When I reboot my Asus N752VX laptop, it often freezes at an early boot stage.
When I'm using GRUB it freezes displaying "Loading initial ramdisk ...".
Adding " initcall_debug earlycon=efifb" to the kernel command, the last kernel messages displayed when it freezes are:
"spurious 8259A interrupt: IRQ7.
calling con_init+0x0/0x25e @ 0
Console: colour dummy device 80x25
printk: console [tty0] enabled
printk: bootconsole [efifb0] disabled"

When the freeze happens the cpu fan starts running at maximum speed and I can only force a shutdown pressing the laptop power button.

This issue is present in all linux, linux-zen and linux-lts since some months.
The only two ways to workaround it are:
1) by avoiding to load the intel-ucode (but it is problematic from the security point of view being the i7-6700hq vulnerable to a lot of Spectre, Meltdown and similar attacks)
2) by adding acpi=off to the kernel command, but in such a case the nvidia driver is not loaded and I have to force a shutdown to complete each reboot. So I'm not sure this second option is able to recreate the freeze because it happens only on reboot and not after a shutdown.

Additional info:
* package version(s) Linux and linux-zen 5.11.2 and previous versions. linux-lts 5.10.20 and previous versions.
* config and/or log files etc.
* This is the link to the forum where are explained all the steps I've made (thanks to the help of other forum users to try to find a solution without luck.

Steps to reproduce:
Reboot the PC until the problem occurs. Typically less than 4 rebooting are sufficient.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 19 September 2021, 08:38 GMT
Reason for closing:  Upstream
Additional comments about closing:  assuming this to be fixed
Comment by Andreas Radke (AndyRTR) - Sunday, 07 March 2021, 09:37 GMT
Doesn't sound like a packaging issue. Please get in touch with upstream kernel/intel-ucode devs.
Comment by Andrea Amorosi (AndreaA) - Sunday, 07 March 2021, 13:43 GMT
I've opened a bug to intel-ucode

Meantime I've seen the issue even when I shutdown and restart. So it is not an issue which happens only when rebooting.
Comment by Andrea Amorosi (AndreaA) - Tuesday, 16 March 2021, 14:44 GMT
I've found a workaroud by reverting to an older BIOS even thought the BIOS I was using had worked for about two years without issues.
Comment by Andreas Radke (AndyRTR) - Wednesday, 01 September 2021, 09:17 GMT
Upstream reports says it should be solved by microcode-20210608 release. Please report back.