Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69822 - [qemu] qemu-bridge-helper is broken

Attached to Project: Arch Linux
Opened by HelloChina (notaplant) - Sunday, 28 February 2021, 09:33 GMT
Last edited by David Runge (dvzrv) - Monday, 29 March 2021, 13:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Anatol Pomozov (anatolik)
David Runge (dvzrv)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Affected version:
qemu-5.2.0-3

The user and group fields on the file /usr/lib/qemu/qemu-bridge-helper are broken in qemu-5.2.0-3, leading to error message

failed to create tun device: Operation not permitted
qemu-system-x86_64: bridge helper failed

User/group of file /usr/lib/qemu/qemu-bridge-helper
qemu-5.2.0-2: user group: root root
qemu-5.2.0-3: user group: colord colord

Steps to reproduce:

Install qemu-5.2.0-3, try to use bridge helper for bridged networking

Fix:

Downgrading to qemu-5.2.0-2 fixes it.
This task depends upon

Closed by  David Runge (dvzrv)
Monday, 29 March 2021, 13:42 GMT
Reason for closing:  Not a bug
Additional comments about closing:  The issue seems artix packaging related and can not be reproduced on Arch Linux
Comment by David Runge (dvzrv) - Sunday, 28 February 2021, 15:31 GMT
@notaplant: Thanks for the report.

I can not reproduce that behavior:

```
$ pacman -Qi qemu
Name : qemu
Version : 5.2.0-3
Description : A generic and open source machine emulator and virtualizer
Architecture : x86_64
URL : https://wiki.qemu.org/
Licenses : GPL2 LGPL2.1
Groups : None
Provides : qemu-headless
Depends On : virglrenderer sdl2 vte3 libpulse libjack.so=0-64 brltty seabios gnutls libpng libaio numactl libnfs lzo snappy curl vde2
libcap-ng spice libcacard usbredir libslirp libssh zstd liburing ndctl dtc
Optional Deps : qemu-arch-extra: extra architectures support
samba: SMB/CIFS server support
qemu-block-iscsi: iSCSI block support
qemu-block-rbd: RBD block support
qemu-block-gluster: glusterfs block support
Required By : cloud-image-utils
Optional For : archiso libvirt
Conflicts With : qemu-headless
Replaces : qemu-kvm
Installed Size : 39.60 MiB
Packager : Anatol Pomozov <anatol.pomozov@gmail.com>
Build Date : 2021-02-08T21:34:15 CET
Install Date : 2021-02-24T10:00:41 CET
Install Reason : Explicitly installed
Install Script : Yes
Validated By : Signature
```

```
$ pacfile /usr/lib/qemu/qemu-bridge-helper
file: usr/lib/qemu/qemu-bridge-helper
owner: qemu
backup: no
mode: 4755
type: file
mtime: 2021-02-08 21:34:15
owner: 0/root
group: 0/root
size: 272.82 K
sha256: 7eb6965455dfa26559cf44ac6a02d33539f96a28a03efb73ea0636064481b828
md5sum: 27dface909b766a1459c39fcbc0b80bd
```

Is this happening reproducibly as soon as you install qemu 5.2.0-3?
Comment by Anatol Pomozov (anatolik) - Sunday, 28 February 2021, 16:06 GMT
I checked machines with installed qemu and qemu-headless packages and both these types have root:root permission.

Please reinstall the package and check if it still fails.

Also the binary above require SUID bit. Make sure you don't mount root with "nosuid" parameter. Please print output of your "mount" to verify it.

Loading...