Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69821 - [firefox-86.0-1] Crashes on start

Attached to Project: Arch Linux
Opened by Ville Aakko (Wild_Penguin) - Sunday, 28 February 2021, 09:18 GMT
Last edited by Jan Alexander Steffens (heftig) - Monday, 01 March 2021, 06:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: Since upgrading to Firefox 86.0-1 I can not start Firefox anymore. Firefox crashes with the standard crash handler dialog immediately, and can not even start in safe mode. This even happens if I move away ~/.mozilla or even on a fresh user home directory (in KDE Plasma).

As a workaround one can downgrade to 0.85. Re-installing (after downgrade) the crash happens again.

Additional info:

Firefox-0.86-1, KDE Plasma and using NVidia proprietary drivers (Macbook Pro 5,5).

Curiously, another computer using amdgpu does not crash. I'm not sure what information would be relevant / helpful for this bug report - any suggestions are welcome!

Steps to reproduce:

1) (Try to) start firefox. Might not happen on all installations, though.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Monday, 01 March 2021, 06:51 GMT
Reason for closing:  Fixed
Additional comments about closing:  86.0-2
Comment by Ville Aakko (Wild_Penguin) - Sunday, 28 February 2021, 09:21 GMT
Realized this sentence is a bit ambiguous / can be mis-interpreted:

> As a workaround one can downgrade to 0.85. Re-installing (after downgrade) the crash happens again.

What I meant, the crash is reproduceable after (re-)upgrading back to 86.0. It does not happen on 85.0.2-1.
Comment by Ville Aakko (Wild_Penguin) - Sunday, 28 February 2021, 09:26 GMT
Output on console while trying to run 86.0.

Additionally, the user gets the "Were Sorry..." -dialog.

Comment by arseru (arseru) - Sunday, 28 February 2021, 13:07 GMT
I'm experiencing the same issue on a MacBookPro8,1 running Arch + i3, with mesa/i915 drivers. The crash does not occur on a Dell computer running also Arch + i3 with the same drivers. I'm attaching the crash details that are sent to mozilla.
Comment by Jan Alexander Steffens (heftig) - Sunday, 28 February 2021, 20:04 GMT
Do you have the IDs of the submitted crashes? You can find them in ~/.mozilla/firefox/Crash\ Reports/submitted .
Comment by arseru (arseru) - Sunday, 28 February 2021, 21:11 GMT Comment by Jan Alexander Steffens (heftig) - Sunday, 28 February 2021, 21:20 GMT
Thanks. That report leads to https://bugzilla.mozilla.org/show_bug.cgi?id=1694670, which has a patch. I'll try to backport it.
Comment by arseru (arseru) - Sunday, 28 February 2021, 21:27 GMT
Awesome, thanks for the help! :)
Comment by Jan Alexander Steffens (heftig) - Sunday, 28 February 2021, 22:34 GMT
Should be fixed in 86.0-2. Can Wild_Penguin confirm?
Comment by arseru (arseru) - Sunday, 28 February 2021, 23:06 GMT
I can confirm it works for me now, thanks again!
Comment by John Barks (Zod) - Sunday, 28 February 2021, 23:27 GMT
I can also confirm, it works.
Comment by Ville Aakko (Wild_Penguin) - Monday, 01 March 2021, 06:18 GMT
Also works here.

Thank You! :-)

Loading...